# Table of Contents

Introduction ........................................ vii
Document Organization ................................ vii
Document Assumptions ................................ viii
Document Conventions ................................ viii
Actel Manuals ......................................... ix
On-Line Help .......................................... xi

1 Setup .................................................. 1
   Software Requirements .............................. 1
   User Setup ......................................... 1
   Project Setup for Viewlogic SpeedWave (PC Only) .... 10

2 Design Flow ......................................... 17
   VHDL VITAL Design Flow Illustrated ................ 17
   VHDL VITAL Design Flow Described .................. 18

3 Generating Netlists .................................. 21
   Generating an EDIF Netlist .......................... 21
   Generating a Structural VHDL Netlist ................. 21

4 VHDL Simulation Using VeriBest .................... 23
   Functional/Behavioral Simulation.................... 23
   Structural Simulation ................................ 24
   Timing Simulation ................................... 25
   Associating Test Benches with Designs ............... 26

5 Simulation with MTI V-System or Model Sim ...... 29
   Behavioral Simulation ................................ 29
   Structural Simulation ................................ 31
   Timing Simulation ................................... 32

6 Simulation With Mentor Graphics QuickHDL ...... 35
   Behavioral Simulation ................................ 35
<table>
<thead>
<tr>
<th>Chapter</th>
<th>Simulation With Cadence Leapfrog</th>
<th>Behavioral Simulation</th>
<th>Structural Simulation</th>
<th>Timing Simulation</th>
</tr>
</thead>
<tbody>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Simulation with Viewlogic SpeedWave</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Simulation with Synopsys VSS</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>A</td>
<td>Product Support</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Index**
List of Figures

Library Search Order dialog box ............................................. 11
FPGA Libraries dialog box .................................................... 12
Actel-VHDL Design Flow ...................................................... 17
Introduction

This VHDL Vital Simulation Guide contains information about using the Model Technology V-System or Model Sim, Mentor Graphics QuickHDL, Cadence Leapfrog, Viewlogic SpeedWave, and Synopsys VSS to simulate designs for Actel devices. Refer to the Designing with Actel manual for additional information about using the Designer software. Refer to the documentation included with your simulator for information about performing simulation.

Document Organization

The VHDL Vital Simulation Guide is divided into the following sections:

Chapter 1 - Setup contains information and procedures about setting up Model Technology’s V-System or Model Sim simulator, the Mentor Graphics QuickHDL simulator, the Cadence Leapfrog simulator, the Viewlogic SpeedWave simulator, and the Synopsys VSS simulator.

Chapter 2 - Design Flow illustrates and describes the VHDL design flow to design an Actel device using Synopsys, ACTmap, or other synthesis tool, and VHDL simulator software.

Chapter 3 - Generating Netlists contains information to allow you to generate a netlist using Synopsys, ACTmap, or other synthesis tool.

Chapter 4 - Simulation with MTI V-System or Model Sim contains information and procedures about simulating for Actel designs using the Model Technology’s V-System or Model Sim simulator.

Chapter 5 - Simulation With Mentor Graphics QuickHDL contains information and procedures about simulating for Actel designs using the Mentor Graphics QuickHDL simulator.

Chapter 6 - Simulation With Cadence Leapfrog contains information and procedures about simulating for Actel designs using the Cadence Leapfrog simulator.
Introduction

Chapter 7 - Simulation with Viewlogic SpeedWave contains information and procedures about simulating for Actel designs using the Viewlogic SpeedWave simulator.

Chapter 8 - Simulation with Synopsys VSS contains information and procedures about simulating for Actel designs using the Synopsys VSS simulator.

Appendix A - Product Support gives information about contacting Actel for customer and technical support.

Document Assumptions

The information in this manual is based on the following assumptions:
1. You have installed the Designer Series software.
2. You have installed your VHDL VITAL simulator.
3. You are familiar with UNIX workstations and UNIX operating systems, or with PCs and Windows operating environments.
4. You are familiar with FPGA architecture and FPGA design software.

Document Conventions

The following conventions are used throughout this manual.

Information that is meant to be input by the user is formatted as follows:

keyboard input

The contents of a file is formatted as follows:

file contents

Messages that are displayed on the screen appear as follows:

Screen Message
The following variables are used throughout this manual.

- Actel FPGA family libraries are shown as `<act_fam>`. Substitute the desired Actel FPGA family `act1`, `act2` (for ACT 2 and 1200XL devices), `act3`, `3200dx`, `40mx`, `42mx`, and `54sx` as needed. For example:

  `edn2vhdl fam:<act_fam> <design_name>`

- Compiled VHDL libraries are shown as `<vhd_fam>`. Substitute `<vhd_fam>` for the desired VHDL family `act1`, `act2` (for ACT 2 and 1200XL devices), `act3`, `a3200dx`, `a40mx`, `a42mx`, and `a54sx` as needed. The VHDL language requires that the library names begin with an alpha character.

### Actel Manuals

The Designer Series software includes printed and on-line manuals. The on-line manuals are in PDF format on the CD-ROM in the “/manuals” directory. These manuals are also installed onto your system when you install the Designer software. To view the on-line manuals, you must install Adobe® Acrobat Reader® from the CD-Rom.

The Designer Series includes the following manuals, which provide additional information on designing Actel FPGAs:

* **Designing with Actel.** This manual describes the design flow and user interface for the Actel Designer Series software, including information about using the ACTgen Macro Builder and ACTmap VHDL Synthesis software.

* **Actel HDL Coding Style Guide.** This guide provides preferred coding styles for the Actel architecture and information about optimizing your HDL code for Actel devices.

* **ACTmap VHDL Synthesis Methodology Guide.** This guide contains information, optimization techniques, and procedures to assist designers in the design of Actel devices using ACTmap VHDL.

* **Silicon Expert User’s Guide.** This guide contains information and procedures to assist designers in the use of Actel’s Silicon Expert tool.
Introduction

*DeskTOP Interface Guide.* This guide contains information about using the integrated VeriBest® and Synplicity® CAE software tools with the Actel Designer Series FPGA development tools to create designs for Actel Devices.

*Cadence® Interface Guide.* This guide contains information and procedures to assist designers in the design of Actel devices using Cadence CAE software and the Designer Series software.

*Mentor Graphics® Interface Guide.* This guide contains information and procedures to assist designers in the design of Actel devices using Mentor Graphics CAE software and the Designer Series software.

*MOTIVE™ Static Timing Analysis Interface Guide.* This guide contains information and procedures to assist designers in the use of the MOTIVE software to perform static timing analysis on Actel designs.

*Synopsys® Synthesis Methodology Guide.* This guide contains preferred HDL coding styles and information and procedures to assist designers in the design of Actel devices using Synopsys CAE software and the Designer Series software.

*Viewlogic Powerview® Interface Guide.* This guide contains information and procedures to assist designers in the design of Actel devices using Powerview CAE software and the Designer Series software.

*Viewlogic Workview Office Interface Guide.* This guide contains information and procedures to assist designers in the design of Actel devices using Workview Office CAE software and the Designer Series software.

*VHDL Vital Simulation Guide.* This guide contains information and procedures to assist designers in simulating Actel designs using a Vital compliant VHDL simulator.

*Verilog Simulation Guide.* This guide contains information and procedures to assist designers in simulating Actel designs using a Verilog simulator.

*Activator and APS Programming System Installation and User’s Guide.* This guide contains information about how to program and debug Actel devices, including information about using the Silicon Explorer diagnostic tool for system verification.
Silicon Sculptor User’s Guide. This guide contains information about how to program Actel devices using the Silicon Sculptor software and device programmer.

Silicon Explorer Quick Start. This guide contains information about connecting the Silicon Explorer diagnostic tool and using it to perform system verification.

Designer Series Development System Conversion Guide UNIX® Environments. This guide describes how to convert designs created in Designer Series versions 3.0 and 3.1 for UNIX to be compatible with later versions of Designer Series.

Designer Series Development System Conversion Guide Windows Environments. This guide describes how to convert designs created in Designer Series versions 3.0 and 3.1 for Windows to be compatible with later versions of Designer Series.

Actel FPGA Data Book. This guide contains detailed specifications on Actel device families. Information such as propagation delays, device package pinout, derating factors, and power calculations are found in this guide.

Macro Library Guide. This guide provides descriptions of Actel library elements for Actel device families. Symbols, truth tables, and module count are included for all macros.

A Guide to ACTgen Macros. This Guide provides descriptions of macros that can be generated using the Actel ACTgen Macro Builder software.

On-Line Help

The Designer Series software comes with on-line help. On-line help specific to each software tool is available in Designer, ACTgen, ACTmap, Silicon Expert, Silicon Explorer, Silicon Sculptor, and APSW.
Setup

This chapter contains information on setting up the Model Technology V-System or Model Sim, Mentor Graphics QuickHDL, Cadence Leapfrog, Viewlogic SpeedWave, or Synopsys VSS simulator to simulate Actel designs.

Included in this chapter are software requirements, steps describing how to compile Actel FPGA libraries, and other setup information for the simulation tool you are using.

Software Requirements

The information in this guide applies to the Actel Designer Series software release R1-1999 or later and IEEE-1076 compliant VHDL simulators. Additionally, this guide contains information about using MTI V-System or Model Sim, Mentor Graphics QuickHDL, Cadence Leapfrog, Viewlogic SpeedWave, and Synopsys VSS simulators.

For specific information about which versions are supported with this release, go to the Guru automated technical support system on the Actel Web site (http://www.actel.com/guru) and type the following in the Keyword box:

third party

User Setup

Before using the Actel VHDL VITAL models with your VHDL simulator, you must compile the Actel FPGA library models.

In addition to the standard Actel libraries, Actel provides a set of migration libraries. These libraries contain macros that were supported in 3.1.1u1 or earlier versions of the Designer Series software and macros that may be needed to retarget designs to a different Actel family. Actel does not recommend using the migration libraries on new designs.

This section describes the compilation procedures for each of the supported simulators.
The following procedures describe how to compile libraries for the Model Technology V-System or Model Sim simulator (UNIX and PC).

**Note:** The procedure shown is for PC. The same setup procedures work similarly for UNIX. Use forward slashes in place of back slashes. For PC, commands are typed into the MTI window. On UNIX, commands are typed at the UNIX command line.

**To compile an Actel VITAL library:**

This procedure compiles an Actel VITAL library in the `"$ALSDIR\lib\vtl\95\mti"` directory. The FPGA library models must be compiled for the Actel VITAL 95 libraries to work properly.

**Note:** If there is already an MTI directory in $ALSDIR\lib\vtl\95 directory, compiled libraries may be present, and the following procedure may not need to be performed.

1. **Create a directory called “mti” in the “$ALSDIR\lib\vtl\95” directory.**

2. **Invoke the V-System simulator (PC only).**

3. **Change to the “$ALSDIR\lib\vtl\95\mti” directory.** Type:

   ```
   cd $ALSDIR\lib\vtl\95\mti
   ```

4. **Create a `<vhd_fam>` family library directory for your simulator.** Type the following command at the prompt:

   ```
   vlib `<vhd_fam>`
   ```

5. **Map the Actel VITAL library to the `<vhd_fam>` directory.** Type the following command at the prompt:

   ```
   vmap `<vhd_fam>` $ALSDIR\lib\vtl\95\mti `<vhd_fam>`
6. **Compile the library.** Type the following command at the prompt:

   \texttt{vcom -work <vhd\_fam> ..\<vhd\_fam>.vhd}

   For example, to compile the 40MX library for your simulator, type the following command:

   \texttt{vcom -work a40mx ..\40mx.vhd}

   \textbf{Note:} Perform the following step only if you are compiling the migration library.

7. **(Optional) Compile the migration library.** Type the following command at the prompt:

   \texttt{vcom -work <vhd\_fam> ..\<act\_fam>_mig.vhd}

The following procedures describe how to compile libraries for Mentor QuickHDL simulator (UNIX).

**To compile the Actel FPGA library models:**

This procedure compiles an Actel VITAL library in the “$ALSDIR/lib/vtl/95/qhdl” directory. The FPGA library models must be compiled for the Actel VITAL 95 libraries to work properly.

1. **Create a directory called “qhdl” in the “$ALSDIR/lib/vtl/95” directory.**

2. **Change to the “$ALSDIR/lib/vtl/95/qhdl” directory.**

3. **Create a <vhd\_fam> family library directory for your simulator.** Type:

   \texttt{qhlib <vhd\_fam>}

4. **Map the Actel VITAL library to the <vhd\_fam> directory.** Type the following command at the prompt:

   \texttt{qhmap <vhd\_fam> $ALSDIR/lib/vtl/95/qhdl/<vhd\_fam>}

5. **Compile the library.** Type the following command at the prompt:

   \texttt{qvcom -work <vhd\_fam> ../<act\_fam>.vhd}
For example, to compile the 40MX library for your simulator, type the following command:

```
qvhcom -work a40mx ../40mx.vhd
```

**Note:** Perform the following step only if you are compiling the migration library.

6. **(Optional) Compile the migration library.** Type the following command at the prompt:

```
qvhcom -work <vhd_fam> ../<act_fam>_mig.vhd
```

The following procedures describe how to compile libraries for the Cadence Leapfrog simulator (UNIX).

**To compile the Actel FPGA library models:**

This procedure compiles an Actel VITAL library in the “$ALSDIR/lib/vtl/95/lfrog” directory. The FPGA library models must be compiled for the Actel VITAL 95 libraries to work properly.

1. **Create a directory called “lfrog” in the “$ALSDIR/lib/vtl/95” directory.**
2. **Change to the “$ALSDIR/lib/vtl/95/lfrog” directory.**
3. **Create a directory named <vhd_fam>.**
4. **Map the library.** Compile the models and create the “cds.lib” file as follows:

   ```
   INCLUDE $CDS/tools/leapfrog/files/cds.lib
   DEFINE <vhd_fam> $ALSDIR/lib/vtl/95/lfrog/<vhd_fam>
   ```

5. **Compile the library.** Type the following command at the prompt:

   ```
   cv -work <vhd_fam> -messages -file $ALSDIR/lib/vtl/95/<act_fam>.vhd
   ```
For example, to compile the 40MX library for your simulator, type the following command:

```
cv -work a40mx -messages -file $ALSDIR/lib/vtl/95/40mx.vhd
```

**Note:** Perform the following step only if you are compiling the migration library.

6. **(Optional) Compile the migration library.** Type the following command at the prompt:

```
cv -work <vhd_fam> -messages -file $ALSDIR/lib/vtl/95/<act_fam>_mig.vhd
```

**Viewlogic’s SpeedWave (PC only)**

The following procedures describe how to compile Actel VITAL libraries for the Viewlogic SpeedWave simulator.

**Note:** If you are using Workview Office 7.31A or 7.4 on a system that uses the FAT16 file system, each compiled Actel VITAL library may take up a large amount of disk space (e.g. over 200MB on a 2GB partition). Go to the Guru automated technical support system on the Actel Web site (http://www.actel.com/guru) for suggestions on how to improve disk space usage.

During the installation of the SpeedWave simulator, you can choose to install the Synopsys IEEE library or the Vantage IEEE library. The Synopsys library is needed for compatibility with the Actel VITAL libraries. The Synopsys library is a superset of the Vantage library.

**To compile an Actel VITAL library in Workview Office 7.31A:**

1. **Create a directory called “swave” in the “c:\actel\lib\vtl\95” directory.**

2. **Set your primary directory.** Invoke Project Manager and use the Browse button to set your primary directory to “c:\actel\lib\vtl\95\swave.” Do not set your library search order.

3. **Save your project and exit Project Manager.**

4. **Invoke SpeedWave.**
5. **Open the VHDL Library Manager dialog box.** Choose the VHDL Library Manager command from the Tools menu or click the VHDL Manager button. The following message appears:

```
VSSLIB.INI does not exist in the directory you are running, create or open one.
```

Click OK. The VHDL Library Manager dialog box is displayed.

6. **Create an `<vhd_fam>` library.** Choose the Create Library command from the File menu. Browse to the “c:\actel\lib\vtl\95\swave” directory and select the `<vhd_fam>.lib` in the Library Path Name box and `<vhd_fam>` in the Symbolic Name box. Click OK.

7. **Add the `<vhd_fam>` library to the Project Libraries.** Choose the `<vhd_fam>.lib` in the “Libraries: *.lib” window and click the Add Lib button.

8. **Add system libraries to search order.** Click the List Sys Libs button. Add the IEEE.LIB and the SYNOPSYS.LIB by selecting each in the “Libraries: *.lib” window and clicking the Add Lib button.

9. **Set the `<vhd_fam>` library as the working library.** Select the “Library: `<md_fam>.lib`” in the Project Libraries window and click the Set Working button.

10. **Create the VSSLIB.INI file.** Choose the Save VSSLIB.INI command from the File menu.

11. **Compile the Actel VITAL library.** Choose the File command from the Analyze menu. The Analyze VHDL File dialog box is displayed. Browse to the “c:\actel\lib\vtl\95” directory and select the `<act_fam>.vhd` file. Click the Analyze button.

12. **Check for compilation errors.** Close the Analyze VHDL File dialog box and return to the VHDL Library Manager dialog box. Check the output console window for warning or error messages.

13. **(Optional) Compile the Actel VITAL migration library.** Choose the File command from the Analyze menu. The Analyze VHDL File dialog box is displayed. Browse to the “c:\actel\lib\vtl\95” directory and select the `<act_fam>_mig.vhd` file. Click the Analyze button.
14. **Check for compilation errors.** Close the Analyze VHDL File dialog box and return to the VHDL Library Manager dialog box. Check the output console window for any warning or error messages.

*To compile an Actel VITAL library in Workview Office 7.4 and 7.5:*

1. **Create a directory called “swave” in the “c:\actel\lib\vtl\95” directory.**
2. **Set your project directory.** Invoke Project Manager and click the New button. Enter “swave” in the Project Name box and “c:\actel\lib\vtl\95\swave” in the Project Directory box. Click the Next button three times, then click the Finish button to complete the process. Do not set your library search order.
3. **Save your project and exit Project Manager.**
4. **Invoke SpeedWave.**
5. **Open the HDL Library Manager window.** Choose the Analyze VHDL Design command from the File menu. Click Cancel in the Welcome dialog box. The HDL Manager window is displayed.
6. **Create a <vhd_fam> library.** Choose the Create User Library command from the File menu (Create command from the Library menu in 7.5). Specify “c:\actel\lib\vtl\95\swave” in the Library Path box and <vhd_fam> in the Symbolic Name box. Click OK.
7. **Add system libraries to search order.** Make sure that the “SYNOPSYS.LIB” and “IEEE.LIB” libraries are listed under the VHDL System Libraries section in the VHDL View window.
8. **Add the Actel VITAL library to the <vhd_fam> library.** Choose the Assign Source File command from the File menu (Add Source Files command from the Library menu in 7.5). Select the <act_fam>.vhd file from the “c:\actel\lib\vtl\95\” directory. Click OK.
9. **Compile the Actel VITAL library.** Select the <act_fam>.vhd file in the VHDL View section of the HDL Manager window. Choose the Analyze Source File command from the Analyze menu.
10. **(Optional) Add the Actel VITAL Migration library to the**<vhd_fam> library. Select the <act_fam>_mig.vhd file from the “c:\actel\lib\vtl\95\” directory. Click OK.

11. **(Optional) Compile the Actel VITAL Migration library.** Select the <act_fam>_mig.vhd file in the VHDL View section of the HDL Manager window. Choose the Analyze Source File command from the Analyze menu.

---

**Compiling Libraries for Viewlogic’s SpeedWave Simulator (UNIX only)**

The following procedures describe how to compile libraries for Viewlogic’s SpeedWave simulator.

During the installation of the SpeedWave simulator, you can choose to install the Synopsys IEEE library or the Vantage IEEE library. The Synopsys library is a superset of the Vantage library and needs to be used with the Actel VITAL libraries.

The following procedures use the Vantage IEEE library. To use the Synopsys IEEE library, use the “-lib $VANTAGE_VSS/pgm/libs/synopsys.lib” switch in the “analyze” and “simulation” commands described below.

**To compile the Actel FPGA library models:**

This procedure compiles an Actel VITAL library in the “$ALSDIR/lib/vtl/95/swave” directory. The FPGA library models must be compiled for the Actel VITAL 95 libraries to work properly.

1. **Create a “swave” directory in the “$ALSDIR/lib/vtl/95” directory.**
2. **Change to the “$ALSDIR/lib/vtl/95/swave” directory.**
3. **Create and map a library directory for your simulator.** Type the following command at the prompt:
   
   \[ \text{vanlibcreate $ALSDIR/lib/vtl/95/swave/<vhd_fam> <vhd_fam>} \]

4. **Compile the library.** Type the following command at the prompt:
   
   \[ \text{analyze -src ../<act_fam>.vhd -lib <vhd_fam> -libieee -lib $VANTAGE_VSS/pgm/lib/synopsys.lib} \]
For example, to compile the 40MX library for your simulator, type the following command:

```
analyze -src ../40mx.vhd -lib a40mx -libieee -lib $VANTAGE_VSS/pgm/lib/synopsys.lib
```

**Note:** Perform the following step only if you are compiling the migration library.

5. **(Optional) Compile the migration library models.** Type the following command at the prompt:

```
analyze -src ../<act_fam>_mig.vhd -lib <vhd_fam> -libieee -lib $VANTAGE_VSS/pgm/lib/synopsys.lib
```

---

**Synopsys VSS Simulator**

The following procedures describe how to compile libraries for the Synopsys VSS simulator (UNIX).

**To compile the Actel VITAL library models:**

This procedure compiles an Actel VITAL library in the “$ALSDIR/lib/vtl/95/vss” directory. The VITAL library models must be compiled prior to using them to simulate.

1. **Create a “vss” directory in the “$ALSDIR/lib/vtl/95” directory.**

2. **Create a <vhd_fam> directory in the “$ALSDIR/lib/vtl/95/vss” directory.**

3. **Using a text editor, create a “.synopsys_vss.setup” file in the “$ALSDIR/lib/vtl/95/vss” directory.** Type the following command at the prompt:

   ```
   <vhd_fam>: ./<vhd_fam>
   default: ./<vhd_fam>
   ```

4. **Change to the “$ALSDIR/lib/vtl/95/vss” directory and compile the library.** Type the following command at the prompt:

   ```
   cd $ALSDIR/lib/vtl/95/vss
   vhdlan -w <vhd_fam> $ALSDIR/lib/vtl/95/<act_fam>.vhd
   ```
For example, to change to the “$ALSDIR/lib/vtl/95/vss” directory and compile the 40MX library for your simulator, type the following command:

```bash
cd $ALSDIR/lib/vtl/95/vss
vhdlan -w a40mx $ALSDIR/lib/vtl/95/40mx.vhd
```

**Note:** Perform the following step only if you are compiling the migration library.

5. **(Optional) Change to the “$ALSDIR/lib/vtl/95/vss” directory and compile the migration library.** Type the following command at the prompt:

```bash
cd $ALSDIR/lib/vtl/95/vss
vhdlan -w <vhd_fam> $ALSDIR/lib/vtl/95/<act_fam>_mig.vhd
```

6. **Check for any warning or error messages.**

### Project Setup for Viewlogic SpeedWave (PC Only)

You must set up an Actel project in the Viewlogic Project Manager for each Actel design before creating your design in Viewlogic. The following procedures describe the process.

**To set up a project in Workview Office 7.31A:**

1. **Invoke Project Manager.**
2. **Set up a new project.** Choose the New command from the File menu.
3. **Set the Primary Directory.** Type the full path name of your design directory or use the Browse button.
4. **Open the Library Search Order dialog box.** Choose the Libraries command from the Project menu.

![Library Search Order dialog box](image)

*Figure 1-1. Library Search Order dialog box*
5. Select an Actel FPGA library. Click the FPGA Lib button (see Figure 1-1). The FPGA Libraries dialog box is displayed (see Figure 1-2). Click the icon of the Actel library you want to select, then click OK.

![FPGA Libraries dialog box](image)

Figure 1-2. FPGA Libraries dialog box

6. Save the project. Choose the Save command from the File menu.

To set up a project in Workview Office 7.4 and 7.5:

1. Invoke Project Manager.
2. Set up a new project. Choose the New command from the File menu. The Creating a New Project wizard is displayed.
3. Set the Project Directory. Type the full path name of your design directory in the Project Directory box or use the Browse button. Type the name of your project in the Project Name box. Click the Next button.
4. Locate your project file. Type the full path name of your project file in the Location of Project File box or use the Browse button. Click the Next button.
5. **Select an Actel FPGA library.** Choose a library in the Configured FPGA Libraries box. Click the icon of the Actel library you want to select, then click Next.

6. **(Optional) Add additional libraries.** Click the Add button and type the full path name of the library you want to add or use the Browse button.

7. **Save the project.** Choose the Save command from the File menu.

---

### Creating a Project Library in SpeedWave

If you use SpeedWave to simulate your designs, you must create a project library in SpeedWave, in addition to creating an Actel project in Project Manager, for each VHDL synthesis-based Actel project. The following procedures describe the process.

**To create a project library in Workview Office 7.31A:**

1. **Invoke SpeedWave.**

2. **Open the VHDL Library Manager dialog box.** Choose the VHDL Manager command from the Tools menu or click the VHDL Manager button. The following message appears if no VSSLIB.INI file is found in your primary directory:

   > VSSLIB.INI does not exist in the directory you are running, create or open one.

   Click OK. The VHDL Library Manager dialog box is displayed.

3. **Create a project design library.** Choose the Create Library command from the File menu. The Create Library dialog box is displayed. Click the Browse button to display the Library Path Name dialog box. Make sure your primary directory is displayed. Type “user.lib” in the File Name box and click OK.

4. **Add the “user.lib” to the Project Libraries.** Click the List User Libs button. Select “user.lib” in the “Libraries: *.lib” window and click the Add Lib button.

5. **Add the compiled Actel VITAL library to the Project Libraries.** Browse to the “c:\actel\lib\vtl\95\swave” directory, select the <vhd_fam>.lib in the “Libraries: *.lib” window, and click the Add Lib
Chapter 1: Setup

button. If you have not compiled the Actel VITAL library, go to “Viewlogic’s SpeedWave (PC only)” on page 5 for the procedure.

Note: Only add the <vhd_fam>.lib if you have referenced Actel macros in your VHDL netlist.

6. **Add system libraries to the Project Libraries.** Click the List Sys Libs button. Add the “IEEE.LIB” and the “SYNOPSYS.LIB” by selecting each in the “Libraries: *.lib” window and clicking the Add Lib button.

7. **Set the “user.lib” as the working library.** Select the “user.lib” in the Project Libraries window and click the Set Working button.

8. **Save the project library.** Choose the Save VSSLIB.INI command from the File menu.

To create a project library in Workview Office 7.4 and 7.5:

1. **Invoke SpeedWave.**

2. **Open the HDL Manager window.** Choose the Analyze VHDL Design command from the File menu. Click Cancel in the Welcome dialog box. The HDL Manager window is displayed.

3. **Setup a project.** Choose the Create User Library command from the File menu (Create command from the Library menu in 7.5). The Create Library dialog box is displayed. Make sure the path in the Library Path box is correct and already exists. Type “user” in the Symbolic Name box and click OK. Make sure no errors are reported in the Output window.

4. **Verify that the “user” library icon appears under the VHDL User Libraries section in the VHDL View window.**

5. **Add the compiled Actel VITAL library to the Project Libraries.** Choose the Add Existing User Library command from the File menu (Add to Workspace command from the Library menu in 7.5). The Add Existing Library to Workspace dialog box is displayed. Click the ellipsis box to open the Select Directory dialog box. Browse to the “c:\actel\lib\vtl\95\swave\<vhd_fam>.lib” directory and click OK. Click OK again in the Add Existing Library to Workspace dialog box. If you have not compiled the Actel VITAL library, go to “Viewlogic’s SpeedWave (PC only)” on page 5 for the procedure.
Project Setup for Viewlogic SpeedWave (PC Only)

Note: Only add the <vhd_fam>.lib if you have referenced Actel macros in your VHDL netlist.

6. **Add system libraries to the Project Libraries.** Make sure the “SYNOPSYS.LIB” and “IEEE.LIB” libraries are listed under VHDL System Libraries in the VHDL View window. If they are not present you must reinstall SpeedWave making sure to choose the Synopsys IEEE libraries when prompted.

7. **Save the project workspace.** Choose the Save command from the File menu.

DeskTOP automatically manages the Actel VITAL libraries. When you create a design and simulate it in the VeriBest VHDL simulator, DeskTOP asks you if you want to compile the VITAL libraries for the Actel family that you have targeted. You should answer “Yes.” Depending on the speed of your PC, it can take approximately 5 – 10 minutes.

Note: If you have not installed the VITAL libraries, compilation will fail. Install VITAL libraries from the DeskTOP CD under the Actel Designer Software if you have not already done so.

Compilation of the VITAL libraries only occurs once for each of the Actel families. After you have compiled the VITAL libraries for a family you do not have to recompile to use the library for any other design targeting that Actel family. You must recompile the libraries if DeskTOP is reinstalled, upgraded, or corrupted.

Note: If you are using DeskTOP on a system that uses the FAT16 file system, each compiled Actel VITAL library may take up a large amount of disk space (e.g. 100MB on a 2GB partition). If you are using Windows 95, you should use FAT32. If you are using Windows NT, you should use NTFS.

**To manually recompile the VITAL libraries:**

1. **Launch DesignView.** Double click the Actel DeskTOP icon on your desktop or navigate to the Actel DeskTOP menu in the Programs section of the Start menu.

2. **Create a new project or open an existing project.**
3. **Select the Project menu, then the Active Configuration command.** Select the “Settings” command in the sub menu.

4. **Click the Vendor Settings tab.** Select the Actel family that you are targeting. Click the Compile VHDL button.

You can verify that the library has been successfully compiled using the log window.
This chapter illustrates and describes the design flow for simulating Actel designs with a VHDL VITAL compliant simulation tool.

VHDL VITAL Design Flow Illustrated

Figure 2-1 shows the design flow for an Actel FPGA using Designer software and a VITAL compliant VHDL simulator.

1. Actel-specific utilities/tools are denoted by the grey boxes in Figure 2-1.
Chapter 2: Design Flow

VHDL VITAL Design Flow Described

The Actel VHDL VITAL design flow has four main steps: Design Creation/Verification, Design Implementation, Programming, and System Verification. These steps are described in detail in the following sections.

**Design Creation/Verification**

During design creation/verification, a design is captured in an RTL-level (behavioral) VHDL source file. After capturing the design, a behavioral simulation of the VHDL file can be performed to verify that the VHDL code is correct. The code is then synthesized into an Actel gate-level (structural) VHDL netlist. After synthesis, an optional structural simulation of the design can be performed. Finally, an EDIF netlist is generated for use in Designer and a VHDL structural netlist is generated for timing simulation in a VHDL VITAL compliant simulator.

**VHDL Source Entry**

Enter your VHDL design source using a text editor or a context-sensitive HDL editor. Your VHDL design source can contain RTL-level constructs as well as instantiations of structural elements, such as ACTgen macros.

**Behavioral Simulation**

You can perform a behavioral simulation of your design before synthesis. Behavioral simulation verifies the functionality of your VHDL code. Typically, zero delays are used and a standard VHDL test bench can be used to drive simulation.

**Synthesis**

After you have created your behavioral VHDL design source, you must synthesize it. Synthesis translates the behavioral VHDL file into a gate-level netlist and optimizes the design for a target technology.

**EDIF Netlist Generation**

After you have created, synthesized, and verified your design, you must generate an Actel EDIF netlist for place and route in Designer.
This EDIF netlist is also used to generate a structural VHDL netlist for use in structural simulation.

**Structural VHDL Netlist Generation**

You can generate a gate-level VHDL netlist from your EDIF netlist for use in structural simulation by either exporting it from Designer or by using the Actel edn2vhdl program.

**Structural Simulation**

You can perform a structural simulation before placing and routing it. Structural simulation verifies the functionality of your post-synthesis structural VHDL netlist. Unit delays included in the compiled Actel VITAL libraries are used.

During design implementation, a design is placed and routed using Designer. Additionally, timing analysis may be performed on a design in Designer with the DT Analyze tool. After place and route, post-layout (timing) simulation is performed with a VHDL VITAL-compliant simulator.

**Place and Route**

Use Designer to place and route your design. Refer to the *Designing With Actel* manual for information about using Designer.

**Timing Analysis**

Use the DT Analyze tool in Designer to perform static timing analysis on your design. Refer to the *Designing With Actel* manual for information about using DT Analyze.

**Timing Simulation**

You perform a timing simulation on your design after placing and routing it. Timing simulation verifies that the design meets your timing constraints.
Chapter 2: Design Flow

**Programming**
You can program a device with programming software and hardware from Actel or a supported 3rd party programming system. Refer to the *Designing With Actel* manual, the *APS Programming System User’s Guide* and the *Silicon Sculptor User’s Guide* for information about programming an Actel device.

**System Verification**
You can perform system verification on a programmed device using the Actel Silicon Explorer diagnostic tool. Refer to the *Activator and APS Programming System Installation and User’s Guide* or *Silicon Explorer Quick Start* for information about using the Silicon Explorer.
This chapter describes the procedures for generating EDIF and structural VHDL netlists.

Generating an EDIF Netlist

After capturing your schematic or synthesizing your design, generate an EDIF netlist from your schematic capture or synthesis tool. The EDIF netlist is used for place and route in Designer. Refer to the documentation included with your schematic capture or synthesis tool for information about generating an EDIF netlist.

Make sure to specify VHDL for the naming style when importing the EDIF netlist into Designer.

Generating a Structural VHDL Netlist

You can generate structural VHDL netlist using Designer or the “edn2vhdl” program. The structural VHDL netlist is used for structural and timing simulation.

To generate a structural netlist using Designer:

1. **Invoke Designer.**
2. **Import the EDIF netlist.** Choose the Import Netlist File command from the File menu. The Import Netlist dialog box is displayed. Specify EDIF as the Netlist Type, GENERIC as the Edif flavor, and VHDL as the Naming Style. Type the full path name of your EDIF netlist or use the Browse button to select your design. Click OK.
3. **Export a structural VHDL netlist.** Choose the Export command from the File menu. The Export dialog box is displayed. Specify Netlist File as the File Type and VHDL as the Format. Click OK.
To generate a structural netlist using “edn2vhdl”:

1. **Change to the directory that contains the VHDL design files.**

2. **Type the following command at the UNIX or DOS prompt:**

   ```
   edn2vhdl FAM:{<act_fam>}
   [ EDNIN:<Edif_File1>[+<Edif_File2...>]]
   [ VHDOUT:<Vhd_file>]
   <design_name>
   ```

   The “EDNIN” option specifies the EDIF input file(s). You can specify multiple files with the “+” delimiter between file names. The default EDIF input file is `<design_name>.edn`. The “VHDOUT” option specifies the VHDL output file names. The default VHDL output file is `<design_name>.vhd`. 
VHDL Simulation Using VeriBest

This chapter describes the procedures for performing functional/behavioral, structural, and timing simulations on an Actel design using the VeriBest VHDL simulator.

Functional/Behavioral Simulation

Use the following procedures to perform a functional/behavioral simulation of an Actel design. Refer to the VeriBest documentation for additional information about performing simulation with the VeriBest VHDL simulator.

1. **Launch DesignView.** Double click the Actel DeskTOP icon on your desktop or navigate to the Actel DeskTOP menu in the Programs section of the Start menu.

2. **In the Hierarchy Manager right click the file you wish to simulate.** The file should have a test bench associated with it, as described in “Associating Test Benches with Designs” on page 26.

3. **Select the Open in Simulator command.** DesignView automatically updates the design files and launches the VeriBest VHDL simulator with the appropriate files. Refer to “Compiling Actel VITAL Libraries” on page 15 for information about updating libraries for VHDL simulation.

4. **Compile your design files and test bench.** Select the Workspace menu, then the Compile All command.

5. **Simulate your design.** Launch the simulator by selecting the Workspace menu, then the Execute Simulator command.

6. **Exit the simulator after simulation is complete.** Select the File menu, then the Exit command.
Structural Simulation

Use the following procedures to perform a structural simulation of an Actel design. Refer to the VeriBest documentation for additional information about performing simulation with the VeriBest VHDL simulator.

1. **Synthesize your design.** You must synthesize your design in order to perform structural simulation. For additional information, refer to “Synthesizing a Design” on page 33 of the Actel DeskTOP Interface Guide or the documentation included with your synthesis tool.

2. **Launch DesignView.** Double-click the Actel DeskTOP icon on your desktop or navigate to the Actel DeskTOP menu in the Programs section of the Start menu.

3. **In the Vendor Manager right click the file under the “Post Synthesis” heading that you wish to simulate.** The file should have a test bench associated with it as described in “Associating Test Benches with Designs” on page 26.

4. **Select the Open Post Synthesis Simulator command.** DesignView automatically updates the design files and launches the VeriBest VHDL simulator with the appropriate files. Refer to “Compiling Actel VITAL Libraries” on page 15 for information about updating libraries for VHDL simulation.

5. **Compile your design files and test bench.** Select the Workspace menu, then the Compile All command.

6. **Simulate your design.** Launch the simulator by selecting the Workspace menu, then the Execute Simulator command.

7. **Exit the simulator after simulation is complete.** Select the File menu, then the Exit command.
Timing Simulation

Use the following procedures to perform a timing simulation on an Actel design. Refer to the VeriBest documentation for additional information about performing simulation with the VeriBest VHDL simulator.

1. **Place and Route your design in Designer and generate an SDF file.** For additional information, refer to Designing with Actel “Place and Route Using Designer” on page 47 of the *Actel DeskTOP Interface Guide*.

2. **Launch DesignView.** Double click the Actel DeskTOP icon on your desktop or navigate to the Actel DeskTOP menu in the Programs section of the Start menu.

3. **In the Vendor Manager right click the file under the “Place-Route Files” heading that you wish to simulate.** The file should have a test bench associated with it as described in “Associating Test Benches with Designs.”

4. **Select the Open Post –Layout Simulator command.** DesignView automatically updates the design files and launches the VeriBest VHDL simulator with the appropriate files. Refer to “Compiling Actel VITAL Libraries” on page 15 for information about updating libraries for VHDL simulation.

5. **Select the SDF file generated during place and route.** Select the Workspace menu, then the Settings command. Select the SDF tab. Select “Min, Typ, or Max” using the radio buttons next to the SDF file to set the delay models used during simulation.

6. **Compile your design files and test bench.** Select the Workspace menu, then the Compile All command.

7. **Simulate your design.** Launch the simulator by selecting the Workspace menu, then the Execute Simulator command.

8. **Exit the simulator after simulation is complete.** Select the File menu, then the Exit command.
Associating Test Benches with Designs

Depending on your design flow, there are several types of simulation you can use to test your design. With VeriBest, the same test bench can be used for functional/behavioral simulation, structural simulation, and timing simulation. The following procedures describe how to associate a test bench during simulation.

**Associating a User Generated Test Bench**

Use the following procedure to associate a test bench before performing any kind of simulation if you have generated a test bench using an HDL editor.

1. **Launch DesignView.** Double click the Actel DeskTOP icon on your desktop or navigate to the Actel DeskTOP menu in the Programs section of the Start menu.
2. **Select the Project menu, then the Add to Project command.**
3. **Select “Add User Stimulus.”**
4. **Browse to the directory that contains the test bench you created.**
5. **Select the appropriate test bench *.vhd file, then click the Open button.**
6. **Link or copy the file into your project.** If you want to make the project portable, select “Copy” to copy the file to your project. Otherwise, select “Link.” The file is displayed under the Simulation Manager tab in DesignView.

**Associating a Test Bench Created in WaveBench**

Use one of the following procedures, depending on the type of simulation you want to perform, to associate a test bench that has been created using WaveBench.

**Associating a Test Bench for Behavioral Simulation**

Use the following procedure to associate a test bench for behavioral simulation (schematic, HDL, or mixed-schematic HDL designs).
1. **Launch DesignView.** Double click the Actel DeskTOP icon on your desktop or navigate to the Actel DeskTOP menu in the Programs section of the Start menu.

2. **In the Hierarchy Manager tab, right click the *.vhd file with which you wish to associate a test bench.**

3. **Select the Associate Stimulus command.** The Associate Stimulus with Block dialog box is displayed.

4. **Select the appropriate *.vhd test bench file.** A small blue wave should appear in the lower left hand corner of the icon of your design file when you return to the Hierarchy Manager tab. This small blue wave signifies that you have successfully associated a stimulus file with the design file.

### Associating a Test Bench for Structural Simulation

Use the following procedure to associate a test bench for structural simulation (for HDL, or mixed-schematic-HDL).

1. **Launch DesignView.** Double click the Actel DeskTOP icon on your desktop or navigate to the Actel DeskTOP menu in the Programs section of the Start menu.

2. **In the Vendor Manager tab, right click the *.vhd file (under the “Synthesis Files” heading) with which you wish to associate a test bench.**

3. **Select the Associate Stimulus command.** The Associate Stimulus with Block dialog box is displayed.

4. **Select the appropriate *.vhd test bench file.** A small blue wave should appear in the lower left hand corner of the icon of your design file when you return to the Hierarchy Manager tab. This small blue wave signifies that you have successfully associated a stimulus file with the design file.

### Associating a Test Bench for Timing Simulation

Use the following procedure to associate a test bench for timing simulation (for schematic, HDL, or mixed-schematic-HDL).

1. **Launch DesignView.** Double click the Actel DeskTOP icon on your desktop or navigate to the Actel DeskTOP menu in the Programs section of the Start menu.
2. **In the Vendor Manager tab, right click the *.vhd file (under the “Synthesis Files” heading) with which you wish to associate a test bench.**

3. **Select the Associate Stimulus command.** The Associate Stimulus with Block dialog box is displayed.

4. **Select the appropriate *.vhd test bench file.** A small blue wave should appear in the lower left hand corner of the icon of your design file when you return to the Hierarchy Manager tab. This small blue wave signifies that you have successfully associated a stimulus file with the design file.
Simulation with MTI V-System or Model Sim

This chapter describes steps to perform Functional (Behavioral and Structural) and Timing simulation for Actel devices using the Model Technology’s V-System or Model Sim simulator.

The procedures shown are for PC. The same setup procedures work similarly for UNIX. Use forward slashes in place of back slashes. For PC, commands are typed into the MTI window. On UNIX, commands are typed into a UNIX window.

Behavioral Simulation

After the VHDL descriptions of the logic blocks have been coded, test and debug the design using the MTI simulator. Use the following procedure to perform behavioral simulation.

Note: Skip step 1 for UNIX platforms.

1. **Invoke your V-System or Model Sim simulator.** For information regarding MTI usage, refer to your Model Technology V-System or Model Sim user’s manual.

2. **Change directory to your project directory.** This directory must include your VHDL design files and testbench. Type:
   
   ```
   cd <project_dir>
   ```

3. **Map to the Actel Library.** If any Actel macros are instantiated in your VHDL source, run the following command to map them to the compiled Actel VITAL library.

   ```
   vmap <vhd_fam> $ALSDIR\lib\vtl\95\mti\<vhd_fam>
   ```

   To reference the Actel family library in your VHDL design files, add the following lines to your VHDL design files:

   ```
   library <vhd_fam>;
   use <vhd_fam>.components.all;
   ```

4. **Create a “work” directory.** Type:

   ```
   vlib work
   ```
5. **Map to the “work” directory.** Type:
   
   ```vmap work .\work```

6. **Perform a behavioral simulation of your design.** To perform a behavioral simulation using your V-System or Model Sim simulator, compile your VHDL design and testbench files and run a simulation. For hierarchical designs, compile the lower level design blocks before the higher level design blocks.

   The following commands demonstrate how to compile VHDL design and testbench files:
   
   ```vcom <behavioral>.vhd```
   ```vcom <test_bench>.vhd```

   To simulate the design, type:
   
   ```vsim <configuration_name>```

   For example:
   
   ```vsim test_adder_behave```

   The entity-architecture pair specified by the configuration named test_adder_behave in the testbench will be simulated.
Structural Simulation

Use the following procedure to perform structural simulation.

1. **Generate a structural VHDL netlist.**
   
   If you are using Synopsys Design Compiler or ACTmap, generate the structural VHDL netlist from these tools.
   
   If you are using other synthesis tools, generate a gate level VHDL from your EDIF netlist by either exporting it from Designer or by using the edn2vhdl program.
   
   **To generate a netlist using edn2vhdl:**
   
   Type:
   
   `edn2vhdl fam:<act_fam> <design_name>`

2. **Map to the Actel VITAL library.** Run the following command to map the compiled Actel VITAL library.
   
   `vmap <vhd_fam> $ALSDIR\lib\vt1\95\mti\<vhd_fam>`

3. **Compile the structural netlist.** Compile your VHDL design and testbench files. The following commands demonstrate how to compile VHDL design and testbench files:
   
   `vcom <structural>.vhd -just e`
   
   `vcom <structural>.vhd -just a`
vcom <test_bench>.vhd

Note: The previous steps compile the entities first, and then the architectures, as required for VHDL netlists written by some tools.

4. Run the structural simulation. To simulate your design, type:

   vsim <configuration_name>

   For example:

   vsim test_adder_structure

   The entity-architecture pair specified by the configuration named test_adder_structure in the testbench will be simulated.

Timing Simulation

Use the following procedure to perform timing simulation.

1. Place and route your design in Designer. Refer to the Designing with Actel manual for information about using Designer.

2. Extract timing information for your design. Choose the Extract command from the Tools menu or click the Extract button. The Extract dialog box is displayed. Create a <design_name>.sdf file by specifying SDF as the CAE type. Click OK.

3. Compile the structural netlist. To perform a timing simulation using your V-System or Model Sim simulator, compile your VHDL design and testbench files, if they have not already been compiled for a structural simulation, and run a simulation. The following commands demonstrate how to compile VHDL design and testbench files:

   vcom <structural>.vhd -just e
   vcom <structural>.vhd -just a
   vcom <test_bench>.vhd
Note: The previous steps compile the entities first, and then the architectures, as required for VHDL netlists written by some tools.

4. **Run the back annotation simulation using the timing information in the SDF file.** Type:

```bash
vsim -sdf[max|typ|min] /<region>=<design name>.sdf -c <configuration_name>
```

The `<region>` option specifies the region (or path) to an instance in a design where back annotation begins. You can use it to specify a particular FPGA instance in a larger system design or testbench that you wish to back annotate. For example:

```bash
vsim -sdfmax /uut=adder.sdf -c test_adder_structural
```

In this example, the entity “adder” has been instantiated as instance “uut” in the testbench. The entity-architecture pair specified by the configuration named “test_adder_structural” in the testbench will be simulated using the maximum delays specified in the SDF file.
Simulation With Mentor Graphics QuickHDL

This chapter describes steps to perform Functional (Behavioral and Structural) and Timing simulation for Actel devices using the Mentor Graphics QuickHDL simulator.

Behavioral Simulation

After the VHDL descriptions of the logic blocks have been coded, test and debug the design using the QuickHDL simulator. Use the following procedure to perform behavioral simulation.

1. **Change directory to your project directory.** This directory must include your VHDL design files and testbench.

2. **Map to the Actel VITAL library.** If any Actel macros are instantiated in your VHDL source, run the following command to map them to the compiled Actel VITAL library.

   ```
   qhmap <vhd_fam> $ALSDIR/lib/vtl/95/qhdl/<vhd_fam>
   ```

   Add the following lines to your VHDL design files to reference the Actel Family library in your VHDL design files:

   ```
   library <vhd_fam>;
   use <vhd_fam>.components.all;
   ```

3. **Create a “work” directory.** Type:

   ```
   qhlib work
   ```

4. **Map to the “work” directory.** Type:

   ```
   qhmap work ./work
   ```

5. **Perform a behavioral simulation of your design.** To perform a behavioral simulation using QuickHDL simulator, compile your VHDL design and testbench files and run a simulation.
The following commands demonstrate how to compile VHDL design and testbench files:

```
qvhcom <behavioral>.vhd
qvhcom <test_bench>.vhd
```

to simulate the design, type:

```
qhsim <configuration_name>
```

where `<configuration_name>` is the name of the configuration that binds the test bench architecture to the test bench entity.

**Structural Simulation**

Use the following procedure to perform structural simulation.

1. **Generate a structural VHDL netlist.**
   - If you are using Synopsys Design Compiler or ACTmap, generate the structural VHDL netlist from these tools.
   - If you are using other synthesis tools, generate a gate level VHDL from your EDIF netlist by either exporting it from Designer or by using the edn2vhdl program.

To generate a netlist using edn2vhdl:

Type:

```
edn2vhdl fam:<act_fam> <design_name>
```

To generate a netlist using Designer Series software:

Select the Import Netlist command from the File menu of the Designer window. Specify EDIF as the Netlist Type, GENERIC as the Edif Flavor, and VHDL as the Naming Style. Use the Browse utility to search for the EDIF netlist of your design.

Select the Export command from the Designer File menu and select Netlist VHDL.
Note: The VHDL generated by both Designer and the edn2vhdl program will use std_logic for all ports. The bus ports will be in the same bit order as they appear in the EDIF netlist.

2. **Map to the Actel VITAL library.** Run the following command to map the compiled Actel VITAL library:

```
qhmap <vhdl_fam> $ALSDIR/lib/vtl/95/qhdl/<vhdl_fam>
```

3. **Compile the structural netlist.** Compile your VHDL design and testbench files. The following commands demonstrate how to compile VHDL design and testbench files:

```
qvhcom <structural>.vhd -just e
qvhcom <structural>.vhd -just a
qvhcom <test_bench>.vhd
```

Note: The previous steps compile the entities first, and then the architectures, as required for VHDL netlists written by some tools.

4. **Run the structural simulation.** To simulate your design, type:

```
qhsim <configuration_name>
```

For example:

```
qhsim test_adder_structure
```

The entity-architecture pair specified by the configuration named test_adder_structure in the testbench will be simulated.

---

**Timing Simulation**

Use the following procedure to perform timing simulation.

1. **Place and route your design in Designer.** Refer to the *Designing with Actel* manual for information about using Designer.

2. **Extract timing information for your design.** Choose the Extract command from the Tools menu or click the Extract button. The
Extract dialog box is displayed. Create a `<design_name>.sdf` file by specifying SDF as the CAE type. Click OK.

3. **Compile the structural netlist.** To perform a timing simulation using the QuickHDL simulator, compile your VHDL design and testbench files, if they have not already been compiled for a structural simulation, and run a simulation. The following commands demonstrate how to compile VHDL design and testbench files:

   ```bash
   qvhcom <structural>.vhd -just e
   qvhcom <structural>.vhd -just a
   qvhcom <test_bench>.vhd
   ```

   **Note:** The previous steps compile the entities first, and then the architectures, as required for VHDL netlists written by some tools.

4. **Run the back annotation simulation using the timing information in the SDF file.** Type:

   ```bash
   qhsim -sdf[max|typ|min] /<region>=<design name>.sdf -c <configuration_name>
   ```

   The `<region>` option specifies the region (or path) to an instance in a design where backannotation begins. You can use it to specify a particular FPGA instance in a larger system design or test bench that you wish to backannotate. For example:

   ```bash
   qhsim -sdfmax /uut=adder.sdf -c test_adder_structural
   ```

   In this example, the entity “adder” has been instantiated as instance “uut” in the testbench. The entity-architecture pair specified by the configuration named “test_adder_structural” in the testbench will be simulated using the maximum delays specified in the SDF file.
Simulation With Cadence Leapfrog

This chapter describes steps to perform Functional (Behavioral and Structural) and Timing simulation for Actel devices using the Cadence Leapfrog simulator.

Behavioral Simulation

After the VHDL descriptions of the logic blocks have been coded, test and debug the design using the Leapfrog simulator. Use the following procedure to perform behavioral simulation.

1. Create a work directory and a cds.lib file in the project directory. At the UNIX prompt, enter:
   
   ```
   mkdir work
   ```

   Using a text editor, create a cds.lib file and enter the following lines:

   ```
   INCLUDE $CDS/tools/leapfrog/files/cds.lib
   ```

2. Map to the Actel VITAL library. If any Actel macros are instantiated in your VHDL source, add the following lines to your cds.lib file to map them to the compiled Actel VITAL library.

   ```
   DEFINE <vhd_fam> $ALSDIR/lib/vtl/95/lfrog/<vhd_fam>
   DEFINE WORK ./work
   ```

   Add the following lines to your VHDL design files to reference the Actel Family library in your VHDL design files:

   ```
   library <vhd_fam>;
   use <vhd_fam>.components.all;
   ```

3. Compile the VHDL design and test bench files. Type:

   ```
   cv -work work -messages -file <behavioral>.vhd
   cv -work work -messages -file <test_bench>.vhd
   ```

4. Elaborate the design. Type:

   ```
   ev -work work -messages <configuration_name>
   ```

   Where `<configuration_name>` is the name of the configuration in the test bench.
For example

```
  ev -work work -messages test_add_behave
```

The entity-architecture pair specified by the configuration named test_adder_behave in the testbench will be elaborated.

If you have instantiated Actel Library Cells in your behavioral VHDL, you must use the -compatibility switch when elaborating your design as shown below:

```
  ev -work work -messages -compatibility <configuration_name>
```

5. Perform a behavioral simulation of your design. Type:

```
  sv -batch -run <configuration_name>
```

Where <configuration_name> is the name of the configuration in the testbench.

For example:

```
  sv -batch -run test_add_behave
```

## Structural Simulation

Use the following procedure to perform structural simulation.

1. **Generate a structural VHDL netlist.**

   If you are using Synopsys Design Compiler or ACTmap, generate the structural VHDL netlist from these tools.

   If you are using other synthesis tools, generate a gate level VHDL from your EDIF netlist by either exporting it from Designer or by using the edn2vhdl program.

   **To generate a netlist using edn2vhdl:**

   Type:

   ```
   edn2vhdl fam:<act_fam> <design_name>
   ```
To generate a netlist using Designer Series software:

Select the Import Netlist command from the File menu of the Designer window. Specify EDIF as the Netlist Type, GENERIC as the Edif Flavor, and VHDL as the Naming Style. Use the Browse utility to search for the EDIF netlist of your design.

Select the Export command from the Designer File menu and select Netlist VHDL.

Note: The VHDL generated by both Designer and edn2vhdl will use std_logic for all ports. The bus ports will be in the same bit order as they appear in the EDIF netlist.

2. Map to the Actel VITAL library. Create a cds.lib file in the project directory as follows:

```
INCLUDE $CDS/tools/leapfrog/files/cds.lib
DEFINE <vhd_fam> $ALSDIR/lib/vtl/95/lfrog/<vhd_fam>
DEFINE WORK ./work
```

3. Compile the VHDL design and test bench files. Type:

```
cv -work work -messages -file <structural>.vhd
cv -work work -messages -file <test_bench>.vhd
```

4. Elaborate the design in compatibility mode. Type:

```
ev -work work -messages -compatibility <configuration_name>
```

Where <configuration_name> is the name of your configuration that binds the test bench entity and architecture.

For example:

```
ev -work work -messages -compatibility test_adder_structure
```

In the example, “test_adder_structure” is the name of configuration for the test bench.

5. Perform a structural simulation of your design. Type:

```
sv -batch -run <configuration_name>
```
Chapter 7: Simulation With Cadence Leapfrog

Where `<configuration_name>` is name of the test bench configuration.

For example:

```
sv -batch -run test_adder_structure
```

Here the name of the test bench configuration is test_adder_structure.

**Timing Simulation**

Use the following procedure to perform timing simulation.

1. **Place and route your design in Designer.** Refer to the *Designing with Actel* manual for information about using Designer.

2. **Extract timing information for your design.** Choose the Extract command from the Tools menu or click the Extract button. The Extract dialog box is displayed. Create a `<design_name>.sdf` file by specifying SDF as the CAE type. Click OK

3. **Map Actel VITAL library.** If not already done for structural simulation, create a `cds.lib` file in the project directory as follows:

   ```
   INCLUDE $CDS/tools/leapfrog/files/cds.lib
   DEFINE <vhd_fam> $ALSDIR/lib/vtl/95/lfrog/<vhd_fam>
   DEFINE WORK ./work
   ```

4. **Compile the VHDL design and test bench files.** If not already done for structural simulation, type:

   ```
   cv -work work -messages -file <structural>.vhd
cv -work work -messages -file <test_bench>.vhd
   ```

5. **Elaborate the design in compatibility mode.** Type:

   ```
   ev -work work -messages -compatibility -bsdf ./<design name>.sdf -bmtm [max|typ|min] -bscope <UUT>
   <configuration_name>
   ```
Where <design_name> is name of top level entity, <UUT> is the instance of the top level entity in the test bench, and <configuration_name> is the name of your configuration that binds the test bench entity and architecture.

For example:
```
ev -work work -messages -compatibility -bsdf adder.sdf -bmtm max -bscope dut test_adder_structure
```

In the above example, “adder” is the name of the top level entity, “test_adder_structure” is the name of configuration for the test bench and “dut” is instance of the top-level entity “adder” in the test bench.

6. **Perform a timing simulation of your design.** Type:

```
sv -batch -run <configuration_name>
```

Where <configuration_name> is name of the test bench configuration.

For example:
```
sv -batch -run test_adder_structure
```

Here the name of the test bench configuration is test_adder_structure.
Simulation with Viewlogic SpeedWave

This chapter describes the procedures for performing simulations on an Actel design using the Viewlogic SpeedWave simulation tool. Refer to the Viewlogic documentation for additional information about performing simulation with SpeedWave.

Behavioral Simulation (PC)

Use the following procedures to perform a behavioral simulation of an Actel design on a PC.

To simulate a design using SpeedWave 7.31A:

1. Select your Actel project in Project Manager. If you have not created your project, go to “Project Setup for Viewlogic SpeedWave (PC Only)” on page 10 for the procedure.

2. Invoke SpeedWave.

3. Open the VHDL Library Manager dialog box. Choose the VHDL Manager command from the Tools menu. If the following message appears:

   VSSLIB.INI does not exist in the directory you are running, create or open one.

   You must create a project library before continuing. Go to “Creating a Project Library in SpeedWave” on page 13 for the procedure.

4. Analyze your behavioral VHDL design files and test bench. Choose the File command from the Analyze menu. The Analyze VHDL File dialog box is displayed. Select each file from the VHDL Source File Name window and click the Analyze button.

   Note: SpeedWave can only simulate configurations. You must have at least one configuration in your test bench.

5. Select a configuration to simulate. Double-click the “user.lib” in the Project Libraries window to display its contents. Select the configuration you want to simulate and click the Simulate Obj button. A SCHEMLES window and a VHDL source window are displayed in the main window.
6. **Simulate your design.** Choose the Run command from the Simulate menu. The Run dialog box is displayed. Select the desired options and click the Apply button. Click the Close button when you have completed your simulation.

To simulate a design using SpeedWave 7.4 and 7.5:

1. **Select your Actel project in Project Manager.** If you have not created your project, go to “Project Setup for Viewlogic SpeedWave (PC Only)” on page 10 for the procedure.

2. **Invoke SpeedWave.**

3. **Open the HDL Manager dialog box.** Choose the Analyze VHDL Design command from the File menu. If the HDL Manager wizard appears, you must create a project library before continuing. Click the Cancel button in the Welcome dialog box and go to “Creating a Project Library in SpeedWave” on page 13 for the procedure.

4. **Open a project HDL workspace (.hws) file.** Choose the Open command from the File menu. Select a .hws file and click the Open button in the Open dialog box.

5. **Analyze your behavioral VHDL design files and test bench.** Select the user library icon in the VHDL User Libraries section of the VHDL View window. Choose the Assign Source Files command from the File menu (Add Source Files command from the Library menu in 7.5). The Assign Source Files dialog box is displayed. Select the behavioral VHDL and test bench files from the VHDL Source File Name window and click OK. Select each file and choose the Analyze Source File command from the Analyze menu. Check the Output window for successful completion. Save the HDL workspace and close the HDL Manager window.

   **Note:** SpeedWave can only simulate configurations. You must have at least one configuration in your test bench.

6. **Select a configuration to simulate.** Choose the Load Design command from the File menu. Double click “user.lib” and select the configuration you want to simulate. Click OK. A Source Viewer window and a Hierarchy Viewer window are displayed.
7. **Simulate your design.** Choose the Run command (Run Simulation command in 7.5) from the Simulate menu. The Run Simulation dialog box is displayed. Select the desired options and click the Apply button. Click the Close button when you have completed your simulation.

---

**Structural Simulation (PC)**

Use the following procedures to perform a structural simulation of an Actel design on a PC.

**To simulate a design using SpeedWave 7.31A:**

1. **Synthesize your design.** Refer to the documentation included with your synthesis tool for information about synthesis.

2. **Select your Actel project in Project Manager.** If you have not created your project, go to “Project Setup for Viewlogic SpeedWave (PC Only)” on page 10 for the procedure.

3. **Invoke SpeedWave.**

4. **Open the VHDL Library Manager dialog box.** Choose the VHDL Manager command from the Tools menu. If the following message appears:

   VSSLIB.INI does not exist in the directory you are running, create or open one.

   You must create a project library before continuing. Go to “Creating a Project Library in SpeedWave” on page 13 for the procedure.

5. **Analyze the your structural VHDL netlist and test bench.** If you have not already generated a structural VHDL netlist, go to “Generating a Structural VHDL Netlist” on page 21 for the procedure. Choose the File command from the Analyze menu. The Analyze VHDL File dialog box is displayed. Select each file from the VHDL Source File Name window and click the Analyze button.

   **Note:** SpeedWave can only simulate configurations. You must have at least one configuration in your test bench.
6. **Select a configuration to simulate.** Double-click the “user.lib” in the Project Libraries window to display its contents. Select the configuration you want to simulate and click the Simulate Obj button. A SCHEMLES window and a VHDL source window are displayed in the main window.

7. **Simulate your design.** Choose the Run command from the Simulate menu. The Run dialog box is displayed. Select the desired options and click the Apply button. Click the Close button when you have completed your simulation.

To simulate a design using SpeedWave 7.4 and 7.5:

1. **Synthesize your design.** Refer to the documentation included with your synthesis tool for information about synthesis.

2. **Select your Actel project in Project Manager.** If you have not created your project, go to “Project Setup for Viewlogic SpeedWave (PC Only)” on page 10 for the procedure.

3. **Invoke SpeedWave.**

4. **Open the HDL Manager dialog box.** Choose the Analyze VHDL Design command from the File menu. If the HDL Manager wizard appears, you must create a project library before continuing. Click the Cancel button in the Welcome dialog box and go to “Creating a Project Library in SpeedWave” on page 13 for the procedure.

5. **Open a project HDL workspace (.hws) file.** Choose the Open command from the File menu. Select a .hws file and click the Open button in the Open dialog box.

6. **Analyze your structural VHDL netlist and test bench.** If you have not already generated a structural VHDL netlist, go to “Generating a Structural VHDL Netlist” on page 21 for the procedure. Select the user library icon in the VHDL User Libraries section of the VHDL View window. Choose the Assign Source Files command from the File menu (Add Source Files command from the Library menu in 7.5). The Assign Source Files dialog box is displayed. Select the structural VHDL netlist and test bench files from the VHDL Source File Name window and click OK. Select each file and choose the Analyze Source File command from the Analyze
Timing Simulation (PC)

Use the following procedures to perform a timing simulation of an Actel design on a PC.

To simulate a design using SpeedWave 7.31A:

1. **Place and route your design in Designer.** Refer to the Designing with Actel manual for information about using Designer.

2. **Extract timing information for your design from Designer.** Choose the Extract command from the Tools menu or click the Extract button. The Extract dialog is displayed. Create a <design_name>.sdf file by choosing the SDF option from the CAE pull-down menu. Click OK.

3. **Select your Actel project in Project Manager.** If you have not created a project, go to “Project Setup for Viewlogic SpeedWave (PC Only)” on page 10 for the procedure.

4. **Invoke SpeedWave.**
5. **Open the VHDL Library Manager dialog box.** Choose the VHDL Manager command from the Tools menu. If the following message appears:

```
VSSLIB.INI does not exist in the directory you are running, create or open one.
```

You must create a project library before continuing. Go to “Creating a Project Library in SpeedWave” on page 13 for the procedure.

6. **(Optional) Analyze your VHDL design files and test bench.** Skip this step if you are using the same structural VHDL netlist and test bench you analyzed for structural simulation. Choose the File command from the Analyze menu. The Analyze VHDL File dialog box is displayed. Select each file from the VHDL Source File Name window and click the Analyze button. Close the dialog box.

   **Note:** SpeedWave can only simulate configurations. You must have at least one configuration in your test bench.

7. **Select a configuration to simulate.** Choose the Load VHDL Design command from the File menu. The Load VHDL Design dialog box is displayed. Click the Design Unit index tab to display the Select Top Level Entity, Architecture, or Configuration window. Double-click the “user.lib” in the window to display its contents. Select the configuration you want to simulate.

8. **Import the timing information for your design.** Click the VITAL Timing index tab. Click the Perform SDF Back Annotation check box and click OK. The Setup SDF Back Annotation dialog box is displayed. Type the name of your `<design_name>.sdf` in the SDF File box or use the Browse button.

9. **Add Scope options.** In the Scope window, fill in the name of the instance in the test bench you want to back annotate (e.g. “/uut”). Select the Delay Mode you want to use (Minimum, Typical, or Maximum). Click the Add button and verify that Scope, File, and Timing settings are correct in the main window. Use the Change and Remove buttons to make any corrections.

10. **Back annotate your design.** Click OK.
11. **Simulate your design.** Choose the Run command from the Simulate menu. The Run dialog box is displayed. Select the desired options and click the Apply button. Click the Close button when you have completed your simulation.

*To simulate a design using SpeedWave 7.4 and 7.5:*

1. **Place and route your design in Designer.** Refer to the *Designing with Actel* manual for information about using Designer.

2. **Extract timing information for your design from Designer.** Choose the Extract command from the Tools menu or click the Extract button. The Extract dialog is displayed. Create a `<design_name>.sdf` file by choosing the SDF option from the CAE pull-down menu. Click OK.

3. **Select your Actel project in Project Manager.** If you have not created a project, go to “Project Setup for Viewlogic SpeedWave (PC Only)” on page 10 for the procedure.

4. **Invoke SpeedWave.**

5. **Open the HDL Manager dialog box.** Choose the Analyze VHDL Design command from the File menu. If the HDL Manager wizard appears, you must create a project library before continuing. Click the Cancel button in the Welcome dialog box and go to “Creating a Project Library in SpeedWave” on page 13 for the procedure.

6. **Open a project HDL workspace (.hws) file.** Choose the Open command from the File menu. Select a .hws file and click the Open button in the Open dialog box.

7. **(Optional) Analyze your VHDL design files and test bench.** Skip this step if you are using the same structural VHDL netlist and test bench you analyzed for structural simulation. Select the user library icon in the VHDL User Libraries section of the VHDL View window. Choose the Assign Source Files command from the File menu (Add Source Files command from the Library menu in 7.5). The Assign Source Files dialog box is displayed. Select the structural VHDL netlist and test bench files from the VHDL Source File Name window and click OK. Select each file and choose the Analyze Source File command from the Analyze menu. Check the Output
window for successful completion. Save the HDL workspace and close the HDL Manager window.

**Note:** SpeedWave can only simulate configurations. You must have at least one configuration in your test bench.

8. **Select a configuration to simulate.** Choose the Load Design command from the File menu. Double click “user.lib” and select the configuration you want to simulate. Click OK. A Source Viewer window and a Hierarchy Viewer window are displayed.

9. **Import the timing information for your design.** Click the VITAL Timing index tab. Click the Perform SDF Back Annotation check box and click OK. The Setup SDF Back Annotation dialog box is displayed. Type the name of your `<design_name>.sdf` in the SDF File box or use the Browse button.

10. **Add Scope options.** In the Scope window, fill in the name of the instance in the test bench you want to back annotate (e.g. “/uut”). Select the Delay Mode you want use (Minimum, Typical, or Maximum). Click the Add button and verify that Scope, File, and Timing settings are correct in the main window. Use the Change and Remove buttons to make any corrections.

11. **Back annotate your design.** Click OK.

12. **Simulate your design.** Choose the Run command (Run Simulation command in 7.5) from the Simulate menu. The Run Simulation dialog box is displayed. Select the desired options and click the Apply button. Click the Close button when you have completed your simulation.
Behavioral Simulation (UNIX)

Use the following procedure to perform a behavioral simulation of an Actel design on UNIX.

1. **Create a working directory.** For more information refer to the Viewlogic manuals. Type:
   ```
   vanlibcreate ./user.lib user
   ```

2. **Create a soft link to the synopsys library.** Type:
   ```
   ln -s $VANTAGE_VSS/pgm/libs/synopsys.lib synopsys
   ```
   **Note:** When installing the Viewlogic SpeedWave simulator, you have the option of installing a pristine IEEE library or the Synopsys version. The Synopsys library is needed for compatibility with the Actel VITAL libraries. If you have installed the Synopsys version you will need to include the Synopsys library in your invocations. The commands in this manual are shown for the Synopsys version of IEEE libraries.

3. **Analyze your vhdl design files and test bench.**
   ```
   analyze -src <behavioral>.vhd -lib user.lib -libieee -lib synopsys
   analyze -src <test_bench>.vhd -lib user.lib -libieee -lib synopsys
   ```

4. **Map to the compiled Actel VITAL library.** If any Actel macros are instantiated in your VHDL source, you must add the following switches when analyzing your VHDL design files:
   ```
   analyze -src <behavioral>.vhd -lib user.lib -lib $ALSDIR/lib/vtl/95/swave/<vhd_fam> -libieee -lib synopsys
   ```
   Add the following lines to your VHDL design files to reference the Actel Family library in your VHDL design files:
   ```
   library <vhd_fam>;
   use <vhd_fam>.components.all;
   ```
5. **Simulate your design.** Type:

```bash
vbsim -cfg <configuration_name> -until complete -lib user.lib -libieee -lib synopsys
```

6. **Map to the compiled Actel VITAL library.** If any Actel macros are instantiated in your VHDL source, you must add the following switches when simulating your VHDL design files:

```bash
vbsim -cfg <configuration_name> -until complete -lib user.lib -libieee -lib synopsys -lib $ALSDIR/lib/vtl/95/swave/<vhd_fam>
```

where `<configuration_name>` is the name of the configuration that binds the test bench entity and architecture.

For example:

```bash
vbsim -cfg test_add_behave -until complete -lib user.lib -libieee -lib synopsys -lib $ALSDIR/lib/vtl/95/swave/a40mx
```

Here the configuration named test_add_behave will be simulated.

**Structural Simulation (UNIX)**

Use the following procedure to perform a structural simulation of an Actel design on UNIX.

1. **Generate a structural VHDL netlist.**

   If you are using Synopsys Design Compiler or ACTmap, generate the structural VHDL netlist from these tools.

   If you are using other synthesis tools, generate a gate level VHDL from your EDIF netlist by either exporting it from Designer or by using the edn2vhdl program.

   **To generate a netlist using edn2vhdl:**

   Type:

   ```bash
   edn2vhdl fam:<act_fam> <design_name>
   ```
To generate a netlist using Designer Series software:

Select the Import Netlist command from the File menu of the Designer window. Specify EDIF as the Netlist Type, GENERIC as the Edif Flavor, and VHDL as the Naming Style. Use the Browse utility to search for the EDIF netlist of your design.

Select the Export command from the Designer File menu and select Netlist VHDL.

Note: The VHDL generated by both Designer and the edn2vhdl program will use std_logic for all ports. The bus ports will be in the same bit order as they appear in the EDIF netlist.

2. Analyze the structural VHDL and the Test bench. Type:

    analyze -src <structural>.vhd -lib user.lib -lib $ALSDIR/lib/vtl/95/swave/<vhd_fam> -libieee -lib synopsys

    analyze -src <test_bench>.vhd -lib user.lib -lib $ALSDIR/lib/vtl/95/swave/<vhd_fam> -libieee -lib synopsys

3. Perform a structural simulation of your design. To perform a structural simulation using your SpeedWave simulator, type:

    vbsim -cfg <configuration_name> -until complete
    -lib user.lib -libieee -lib synopsys -lib $ALSDIR/lib/vtl/95/swave/<vhd_fam>

For example:

    vbsim -cfg test_add_structure -until complete -lib user.lib -libieee -lib synopsys -lib $ALSDIR/lib/vtl/95/swave/a40mx

Here the configuration specified by test_add_structure will be simulated.

Timing Simulation (UNIX)

Use the following procedure to perform a timing simulation of an Actel design on UNIX.
1. **Compile the structural netlist.** To perform a timing simulation using your SpeedWave simulator, compile your VHDL design and testbench files, if not already done for structural simulation, and run simulation.

   The following commands demonstrate how to compile VHDL design and testbench files:

   ```
   analyze -src <structural>.vhd -lib user.lib -lib $ALSDIR/lib/vtl/95/swave/<vhd_fam> -libieee -lib synopsys
   
   analyze -src <test_bench>.vhd -lib user.lib -lib $ALSDIR/lib/vtl/95/swave/<vhd_fam> -libieee -lib synopsys
   ```

2. **Run the back annotation simulation using the timing information from the SDF file.** Type:

   ```
   vbsim -cfg <configuration_name> -until complete -lib user.lib -libieee -lib synopsys -lib $ALSDIR/lib/vtl/95/swave/<vhd_fam> -sdf <design_name>.sdf <UUT> -sdfmode [min|typ|max]
   ```

   Where `<configuration_name>` is the name of your configuration that binds the test bench entity and architecture, `<design_name>` is name of top level entity, `<UUT>` is the instance of the top level entity in the test bench.
This chapter describes steps to perform Functional (Behavioral and Structural) and Timing simulation for Actel devices using the Synopsys VSS simulator.

**Behavioral Simulation**

After the VHDL descriptions of the logic blocks have been coded, test and debug the design using the VSS simulator. Use the following procedure to perform behavioral simulation.

1. **Create a working directory.** Use the UNIX `mkdir` command to create a directory for VSS to use as your working directory.
   
   ```
   mkdir work
   ```

2. **Using a text editor, create a “.synopsys_vss.setup” file in your current directory containing the following lines:**
   
   ```
   work > default
default: ./work
   ```

3. **Map to the compiled Actel VITAL library.** If any Actel macros are instantiated in your VHDL source, you must add the following line to your “.synopsys_vss.setup” file:
   
   `<vhd_fam>: $ALSDIR/lib/vtl/95/vss/<vhd_fam>`

4. **Analyze your VHDL design files and test bench.** Use the `vhdlan` command to compile your VHDL source files:
   
   ```
   vhdlan <behavioral>.vhd
   vhdlan <test_bench>.vhd
   ```

5. **Create a vss.dofile to run simulation in batch mode.** Enter the following lines:
   
   ```
   run
   quit
   ```

6. **Simulate your design.** Use the `vhdlssim` command to simulate your testbench configuration:
   
   ```
   vhdlssim -t ps -i vss.dofile <configuration_name>
   ```
Structural Simulation

Use the following procedure to perform structural simulation.

1. **Generate a structural VHDL netlist.**
   
   If you are using Synopsys Design Compiler or ACTmap, generate the structural VHDL netlist from these tools.

   If you are using other synthesis tools, generate a gate level VHDL from your EDIF netlist by either exporting it from Designer or by using the edn2vhdl program.

   **To generate a netlist using edn2vhdl:**
   
   Type:
   
   `edn2vhdl fam:<act_fam> <design_name>`

   **To generate a netlist using Designer Series software:**
   
   Select the Import Netlist command from the File menu of the Designer window. Specify EDIF as the Netlist Type, GENERIC as the Edif Flavor, and VHDL as the Naming Style. Use the Browse utility to search for the EDIF netlist of your design.

   Select the Export command from the Designer File menu and select Netlist VHDL.

   **Note:** The VHDL generated by both Designer and the edn2vhdl program will use std_logic for all ports. The bus ports will be in the same bit order as they appear in the EDIF netlist.

2. **Analyze your structural VHDL netlist and test bench.** Use the `vhdlan` command to compile your VHDL source files:

   `vhdlan <structural>.vhd`
   `vhdlan <test_bench>.vhd`

3. **Simulate your design.** Use the `vhdlssim` command to simulate your testbench configuration:

   `vhdlssim -t ps -i vss.dofile <configuration_name>`
Timing Simulation

Use the following procedure to perform timing simulation.

1. **Place and route your design in Designer.** Refer to the Designing with Actel manual for information about using Designer.

2. **Extract timing information for your design.** Choose the Extract command from the Tools menu or click the Extract button. The Extract dialog box is displayed. Create a `<design_name>.sdf` file by specifying SDF as the CAE type. Click OK.

3. **Analyze your structural VHDL netlist and test bench.** Use the `vhdlan` command to compile your VHDL source files:

   
   vhdlan <structural>.vhd
   vhdlan <test_bench>.vhd

4. **Simulate your design using SDF back annotation.** Use the `vhdlsim` command with the SDF back annotation options to simulate your test bench configuration:

   vhdlan -t ps -i vss.dofile -sdf_max -sdf_top <top_entity_name>/<instance_name> -sdf <design_name>.sdf <configuration_name>

   Substitute “-sdf_min” or “-sdf_typ” for “-sdf_max” to use the minimum, typical delays, or maximum respectively. Substitute the name of your configuration that binds the test bench entity and architecture for `<configuration_name>`, the top-level entity in your test bench for `<top_entity_name>`, and the instance of the design for `<instance_name>`.

59
Product Support

Actel backs its products with various support services including Customer Service, a Customer Applications Center, a Web and FTP site, electronic mail, and worldwide sales offices. This appendix contains information about using these services and contacting Actel for service and support.

Actel U.S. Toll-Free Line

Use the Actel toll-free line to contact Actel for sales information, technical support, requests for literature about Actel and Actel products, Customer Service, investor information, and using the Action Facts service.

The Actel Toll-Free Line is (888) 99-ACTEL.

Customer Service

Contact Customer Service for non-technical product support, such as product pricing, product upgrades, update information, order status, and authorization.

From Northeast and North Central U.S.A., call (408) 522-4480.
From Southeast and Southwest U.S.A., call (408) 522-4480.
From South Central U.S.A., call (408) 522-4434.
From Northwest U.S.A., call (408) 522-4434.
From Canada, call (408) 522-4480.
From Europe, call (408) 522-4252 or +44 (0) 1256 305600.
From Japan, call (408) 522-4743.
From the rest of the world, call (408) 522-4743.
Fax, from anywhere in the world (408) 522-8044.
Appendix A: Product Support

Customer Applications Center

The Customer Applications Center is staffed by applications engineers who can answer your hardware, software, and design questions.

All calls are answered by our Technical Message Center. The center retrieves information, such as your name, company name, phone number and your question, and then issues a case number. The Center then forwards the information to a queue where the first available application engineer receives the data and returns your call. The phone hours are from 7:30 a.m. to 5 p.m., Pacific Standard Time, Monday through Friday.

The Customer Applications Center number is (800) 262-1060.

European customers can call +44 (0) 1256 305600.

Guru Automated Technical Support

Guru is a Web based automated technical support system accessible through the Actel home page (http://www.actel.com/guru/). Guru provides answers to technical questions about Actel products. Many answers include diagrams, illustrations and links to other resources on the Actel Web site. Guru is available 24 hours a day, seven days a week.

Web Site

Actel has a World Wide Web home page where you can browse a variety of technical and non-technical information. Use a Net browser (Netscape recommended) to access Actel's home page.

The URL is http://www.actel.com. You are welcome to share the resources we have provided on the net.

Be sure to visit the “Actel User Area” on our Web site, which contains information regarding: products, technical services, current manuals, and release notes.
FTP Site

Actel has an anonymous FTP site located at ftp://ftp.actel.com. You can directly obtain library updates, software patches, design files, and data sheets.

Electronic Mail

You can communicate your technical questions to our e-mail address and receive answers back by e-mail, fax, or phone. Also, if you have design problems, you can e-mail your design files to receive assistance. The e-mail account is monitored several times per day.

The technical support e-mail address is tech@actel.com.
Appendix A: Product Support

Worldwide Sales Offices

Headquarters
Actel Corporation
955 East Arques Avenue
Sunnyvale, California 94086
Toll Free: 888.99.ACTEL
Tel: 408.739.1010
Fax: 408.739.1540

US Sales Offices

California
Bay Area
Tel: 408.328.2200
Fax: 408.328.2358
Irvine
Tel: 949.727.0470
Fax: 949.727.0476
San Diego
Tel: 619.938.9860
Fax: 619.938.9887
Thousand Oaks
Tel: 805.375.5769
Fax: 805.375.5749

Colorado
Tel: 303.420.4335
Fax: 303.420.4336

Florida
Tel: 407.677.6661
Fax: 407.677.1030

Georgia
Tel: 770.831.9090
Fax: 770.831.0055

Illinois
Tel: 847.259.1501
Fax: 847.259.1572

Maryland
Tel: 410.381.3289
Fax: 410.290.3291

Massachusetts
Tel: 978.244.3800
Fax: 978.244.3820

Minnesota
Tel: 612.854.8162
Fax: 612.854.8120

North Carolina
Tel: 919.376.5419
Fax: 919.376.5421

Pennsylvania
Tel: 215.830.1458
Fax: 215.706.0680

Texas
Tel: 972.235.8944
Fax: 972.235.965

International Sales Offices

Canada
Suite 203
135 Michael Cowpland Dr.
Kanata, Ontario K2M 2E9
Tel: 613.591.2074
Fax: 613.591.0348

France
361 Avenue General de Gaulle
92147 Clamart Cedex
Tel: +33 (0)1.40.83.11.00
Fax: +33 (0)1.40.94.11.04

Germany
Bahnhofstrasse 15
85375 Neufahrn
Tel: +49 (0)8165.9584.0
Fax: +49 (0)8165.9584.1

Hong Kong
Suite 2206,
Parkside Pacific Place,
88 Queensway
Tel: +852.2877.6226
Fax: +852.2818.9693

Italy
Via Giovanni da Udine No. 34
20156 Milano
Tel: +39 (0)2.3809.3259
Fax: +39 (0)2.3809.3260

Japan
EXOS Ebisu Building 4F
1-24-14 Ebisu Shibuya-ku
Tokyo 150
Tel: +81 (0)3.3445.7671
Fax: +81 (0)3.3445.7668

Korea
155-000, 18th Floor,
Kyung Am Bldg
157-27 Samsung-dong
Kangnam-ku, Seoul
Tel: +82 (0)2.555.7425
Fax: +82 (0)2.555.5779

Taiwan
4F-3, No. 75, Sec. 1,
Hsin-Tai-Wu Road,
Hsi-chih, Taipei, 221
Tel: +886 (0)2.698.2525
Fax: +886 (0)2.698.2548

United Kingdom
Daneshill House,
Lutyens Close
Basingstoke,
Hampshire RG24 8AG
Tel: +44 (0)1256.305600
Fax: +44 (0)1256.355420
Index

A
Actel
  FPGA Libraries 12, 13
  FTP Site 63
  Manuals ix
  Web Based Technical Support 62
  Web Site 62
Actel Project Setup 10, 15
  Project Manager 10
  SpeedWave 13
Actel VITAL Libraries
  Adding to the Project Library 14
  Creating a swave Directory 5, 7
Adding
  Actel VITAL Libraries to the Project Library 14
  Libraries 13
  System Libraries to the Search Order 14
  User Libraries to the Search Order 13
Analyzing
  Test Bench 45, 46, 48, 50, 51
  VHDL Source File 45, 46, 47, 48, 50, 51
Associating Test Benches 26
  Behavioral Simulation 26
  Post-Layout Simulation 27
  Post-Synthesis Simulation 27
Assumptions viii

B
Back Annotate 50, 52
Backannotation
  SDF with VHDL Simulation 25
Behavioral Simulation 18, 23, 45
  Associating Test Benches 26
  Cadence Leapfrog Simulator 39
  Mentor Graphics QuickHDL Simulator 35
  Model Technology V-System Simulator 29
  SpeedWave 18, 45
  VeriBest VHDL 23

C
Capturing a Design
  VHDL-Based 18
Compiling
  Actel FPGA library models 1
  Configuration 45, 46, 49, 50, 52
Contacting Actel
  Customer Service 61
  Electronic Mail 63
  Technical Support 62
  Toll-Free 61
  Web Based Technical Support 62
Conventions viii
  Document viii
Creating
  Project Library 13
  SDF File 49, 51
  swave Directory 5, 7
  VSSLIB.INI File 6, 13
  Customer Service 61

D
Delay Mode 50, 52
Design Creation/Verification 18
  Behavioral Simulation 18
  EDIF Netlist Generation 18
  Structural Simulation 19
  VHDL Source Entry 18
Design Flow
  Design Creation/Verification 18
  Design Implementation 19
  Schematic-Based ??–20
Index

Design Implementation 19
- Place and Route 19
- Timing Analysis 19
- Timing Simulation 19
Design Layout 19
- Model Technology V-System Simulator 33
Designer
- DT Analyze Tool 19
- EDIF Option 21
- Extracting Timing Information 49, 51
- GENERIC Option 21
- Place and Route 19
- SDF Option 49, 51
- Software Installation Directory viii
- Structural Netlist Generation 21
- Timing Analysis 19
- VHDL Option 19, 21
- VIEWLOGIC Option 19
Device
- Verification 20
- Device Programming 20
- Document Assumptions viii
- Document Conventions viii, viii
- DT Analyze
  - Static Timing Analysis 19

\textit{E}
- EDIF Netlist Generation 21
- Synthesis-Based 18
- EDIF Option 21
- edn2vhdl 22
- Electronic Mail 63
- Extracting Timing Information 49, 51

\textit{F}
- FPGA Libraries 12, 13
- Functional Simulation 23

\textit{G}
- Generating
  - EDIF Netlist 18, 21
  - Structural Netlist 21
- Generating an EDIF netlist
  - Cadence Leapfrog Simulator 40
  - Mentor Graphics QuickHDL Simulator 36
  - Model Technology V-System Simulator 31
  - Viewlogic Vantage Speedwave Simulator 54
- GENERIC Option 21

\textit{I}
- Importing Timing Information 50, 52
- Installation Directory
  - Designer viii
  - Workview Office viii

\textit{L}
- Libraries
  - Actel FPGA 12, 13
  - Compiling 15
  - IEEE 14
  - Project 13
  - Recompiling 16
  - Synopsys 14
  - System 14
  - User 13
  - VITAL 15
- Library Search Order 11

\textit{N}
- Netlist Generation
  - EDIF 18
Index

O
On-Line Help xi

P
Place and Route 19
Post-Layout Simulation
  Associating Test Benches 27
Post-Synthesis Simulation 19
  Associating Test Benches 27
Primary Directory 10, 12
Product Support 61–??
  Customer Applications Center 62
  Customer Service 61
  Electronic Mail 63
  FTP Site 63
  Technical Support 62
  Toll-Free Line 61
  Web Site 62
Programming a Device 20
Project Library 13
Project Manager
  Library Search Order 11
  Project Setup 10
  Selecting an Actel FPGA Library 12, 13
  Setting the Primary Directory 10, 12
Project Setup 15
  Project Manager 10
  SpeedWave 13

R
Recompiling VITAL Libraries 16
Related Manuals ix

S
Schematic-Based Design Flow ??–20
  System Verification 20

  SCHEMLES Window 45
  Scope Options 50, 52
  SDF Backannotation
    VHDL Simulation with 25
  SDF File 49, 51
  SDF Option 49, 51
  Selecting an Actel FPGA Library 12, 13
  Selecting Scope Options 50, 52
  Setting the Primary Directory 10, 12
  Setting the Working Library 14
  Setting Up
    an Actel Project in Project Manager 10
    an Actel Project in SpeedWave 13
  Setup Procedure
    Cadence Leapfrog Simulator (VITAL 95) 2, 3, 4, 5
    Mentor Graphics Quick HDL Simulator (VITAL 95) 3
    Model Technology V-System Simulator
      VITAL 95 2
  Setup Procedures 15
    Creating a Project Library 13
    Project Setup 15
    Setting Up an Actel Project 10
    User Setup 8
  Simulation
    Behavioral 18, 45
    Configuration 45, 46, 48, 49, 50, 52
    Functional/Behavioral 23
    Post-Synthesis 19
    SpeedWave 18, 19, 45–51
    Structural 19, 24, 47
    Synthesis-Based 18, 19, 45–51
    Test Bench 45, 46, 48, 49, 50, 52
    Timing 19, 25
    SpeedWave
Index

Behavioral Simulation 18, 45
Creating a Project Library 13
Importing Timing Information 50, 52
Post-Synthesis Simulation 19
Scope Options 50, 52
Structural Simulation 19, 47
Timing Simulation 19
Static Timing Analysis 19
Structural Netlist Generation
  Designer 21
  EDIF Option 21
edn2vhdl 22
  GENERIC Option 21
Structural Simulation 19, 47
  Cadence Leapfrog Simulator 40
  Mentor Graphics QuickHDL Simulator 36
  Model Technology V-System Simulator 31
  SpeedWave 19, 47
  VeriBest VHDL 25
  Viewlogic Vantage Speedwave Simulator 54
swave Directory 5, 7
System Libraries 14
System Verification 20
  Silicon Explorer 20

T
Technical Support 62
Test Bench 45, 46, 47, 48, 50, 51
  Modifying 19
Test Benches
  Associating with Design 26
  Behavioral Simulation 26
  Post-Layout Simulation 27
  Post-Synthesis Simulation 27
Timing Analysis 19
Timing Information 49, 50, 51, 52

SDF File 49, 51
Timing Simulation 19
  SDF Option 49, 51
  SpeedWave 19
  VeriBest VHDL 25
  Toll-Free Line 61

U
Unit Delays 18
User Library 13
User Setup 8

V
VeriBest
  VHDL Simulation 23
VHDL
  Option 21
  VHDL Option 19
  VHDL Simulation 23
    Behavioral 23
    SDF Backannotation 25
    Structural 24
    Timing 25
  VHDL Source Entry 18
  VHDL Source File
    Analyzing 45, 46, 47, 48, 50, 51
  VHDL Synthesis-Based Design Flow
    Design Creation/Verification 18
    Design Implementation 19
    Programming 20
  VIEWLOGIC Option 19
  VITAL Libraries 15
    Steps to Manually Recompile 16
  VSSLIB.INI File
    Creating 6, 13
    Does Not Exist 6, 13, 45, 47, 50
W
Web Based Technical Support 62
Working Library 14
Workview Office
   Software Installation Directory viii