# Table of Contents

**Introduction** .................................................. v
Document Organization ......................................... v
Document Assumptions ........................................ vi
Document Conventions .......................................... vi
Your Comments .................................................... vii
Actel Manuals ..................................................... vii
Online Help ......................................................... ix

1 **Setup** .......................................................... 11
   Software Requirements ....................................... 11
   Actel Libraries ............................................... 11
   Migration Libraries ......................................... 11
   User Setup ...................................................... 12
   Project Setup .................................................. 15

2 **Actel-Innoveda Design Flow** ................................. 17
   Schematic-Based Design Flow Illustrated .................. 17
   Schematic-Based Design Flow Overview ...................... 18
   VHDL Synthesis-Based Design Flow Illustrated .......... 20
   VHDL Synthesis-Based Design Flow Overview .............. 21

3 **Actel-Innoveda Design Considerations** ...................... 25
   Naming Conventions ........................................... 25
   Adding Pins to the Schematic ................................ 25
   Generating a Top-Level Symbol ................................ 26
   Buried I/Os ...................................................... 26
   Adding Power and Ground ..................................... 26
   Sheets and Symbols ............................................ 26
   Assigning Pins in a Schematic ................................ 27
   Adding ACTgen Macros ....................................... 27
   Adding FPGA Express Blocks ................................. 28
   Generating an EDIF Netlist .................................... 29
   Generating a Structural VHDL Netlist ....................... 29
# Table of Contents

Using FPGA Express with SpeedWave ............................................. 30  
Using FPGA Express with ViewSim ............................................. 31

4 Simulation Using ViewSim ......................................................... 33  
   Functional Simulation ......................................................... 33  
   Timing Simulation ............................................................. 34  
   Multichip Simulation .......................................................... 35

5 Simulation Using SpeedWave ....................................................... 37  
   Behavioral Simulation .......................................................... 37  
   Structural Simulation .......................................................... 38  
   Timing Simulation ............................................................... 39

A Product Support ........................................................................... 41  
   Actel U.S. Toll-Free Line ......................................................... 41  
   Customer Service .................................................................... 41  
   Customer Applications Center .................................................. 42  
   Guru Automated Technical Support .......................................... 42  
   Web Site ................................................................................. 42  
   FTP Site ................................................................................. 43  
   Contacting the Customer Applications Center ............................ 43  
   Worldwide Sales Offices ......................................................... 44
Introduction

The Innoveda® eProduct Designer Interface Guide contains information about using the Innoveda eProduct Designer CAE software tools with the Actel Designer Series FPGA development software tools to create designs for Actel devices. Refer to the Getting Started User’s Guide for additional information about using the Designer series software and the Innoveda documentation for information about using the eProduct Designer software.

Document Organization

The Innoveda eProduct Designer Interface Guide contains the following chapters:

Chapter 1 - Setup contains information about setting up the eProduct Designer software for use in creating Actel designs.

Chapter 2 - Design Flow describes the design flow for creating Actel designs using eProduct Designer software and Designer Series software.

Chapter 3 - Actel-Innoveda Design Considerations contains information to assist you in creating Actel designs with eProduct Designer and Designer Series software.

Chapter 4 - Simulation Using ViewSim® contains information about simulating Actel designs with ViewSim.

Chapter 5 - Simulation Using SpeedWave™ contains information about simulating Actel designs with SpeedWave.

Appendix A - Product Support provides information about contacting Actel for customer and technical support.
**Document Assumptions**

This document assumes the following:

1. You have installed the Designer Series software in the “C:\Actel” directory.
2. You have installed the eProduct Designer software in the “C:\ePD” directory.
3. You are familiar with PCs and Windows operating environments.
4. You are familiar with FPGA architecture and FPGA design software.

**Document Conventions**

This document uses the following conventions:

Information input by the user follows this format:

```
keyboard input
```

The content of a file follows this format:

```
file contents
```

The `<act_fam>` variable represents an Actel device family. To reference an actual family, substitute the name of the Actel device when you see this variable. Available families are act1, act2 (for ACT 2 and 1200XL devices), ACT3, 3200DX, 40MX, 42MX, and 548X, 548X-A and eX.

The `<vhd_fam>` variable represents Compiled VHDL libraries. To reference an actual compiled library, substitute the name of the library (act1, act2 (for ACT 2 and 1200XL devices), ACT3, A3200DX, A40MX, A42MX, A548X, and eX) when you see this variable. Compiled VHDL libraries must begin with an alpha character.
Your Comments

Actel Corporation strives to produce the highest quality online help and printed documentation. We want to help you learn about our products, so you can get your work done quickly. We welcome your feedback about this guide and our online help. Please send your comments to documentation@actel.com.

Actel Manuals

Designer and Libero include printed and online manuals. The online manuals are in PDF format and available from Libero and Designer's Start Menus and on the CD-ROM. From the Start menu choose:

- Programs > Libero 2.2 > Libero 2.2 Documentation.
- Programs > Designer Series > R1-2002 Documentation

Also, the online manuals are in PDF format on the CD-ROM in the “/manuals” directory. These manuals are also installed onto your system when you install the Designer software. To view the online manuals, you must install Adobe® Acrobat Reader® from the CD-ROM.

The Designer Series includes the following manuals, which provide additional information on designing Actel FPGAs:

- **Getting Started User's Guide.** This manual contains information for using the Designer Series Development System software to create designs for, and program, Actel devices.

- **Designer User's Guide.** This manual provides an introduction to the Designer series software as well as an explanation of its tools and features.

- **PinEdit User's Guide.** This guide provides a detailed description of the PinEdit tool in Designer. It includes cross-platform explanations of all the PinEdit features.

- **ChipEdit User's Guide.** This guide provides a detailed description of the ChipEdit tool in Designer. It includes a detailed explanation of the ChipEdit functionality.
Timer User's Guide. This guide provides a detailed description of the Timer tool in Designer. It includes a detailed explanation of the Timer functionality.

SmartPower User's Guide. This guide provides a detailed description of using the SmartPower tool to perform power analysis.

Netlist Viewer User's Guide. This guide provides a detailed description of the Netlist Viewer. Information on using the Netlist Viewer with Timer and ChipEdit to debug your netlist is provided.

A Guide to ACTgen Macros. This Guide provides descriptions of macros that can be generated using the Actel ACTgen Macro Builder software.

Actel HDL Coding Style Guide. This guide provides preferred coding styles for the Actel architecture and information about optimizing your HDL code for Actel devices.

Silicon Expert User's Guide. This guide contains information to assist designers in the use of Actel’s Silicon Expert tool.

Cadence® Interface Guide. This guide contains information to assist designers in the design of Actel devices using Cadence CAE software and the Designer Series software.

Mentor Graphics® Interface Guide. This guide contains information to assist designers in the design of Actel devices using Mentor Graphics CAE software and the Designer Series software.

Synopsys® Synthesis Methodology Guide. This guide contains preferred HDL coding styles and information to assist designers in the design of Actel devices using Synopsys CAE software and the Designer Series software.

Innoveda® eProduct Designer Interface Guide (Windows). This guide contains information to assist designers in the design of Actel devices using eProduct Designer CAE software and the Designer Series software.

VHDL Vital Simulation Guide. This guide contains information to assist designers in simulating Actel designs using a Vital compliant VHDL simulator.
Verilog Simulation Guide. This guide contains information to assist designers in simulating Actel designs using a Verilog simulator.

Activator and APS Programming System Installation and User’s Guide. This guide contains information about how to program and debug Actel devices, including information about using the Silicon Explorer diagnostic tool for system verification.

Silicon Sculptor User’s Guide. This guide contains information about how to program Actel devices using the Silicon Sculptor software and device programmer.

Flash Pro User’s Guide. This guide contains information about how to program Actel ProASIC and ProASIC PLUS devices using the Flash Pro software and device programmer.

Silicon Explorer II. This guide contains information about connecting the Silicon Explorer diagnostic tool and using it to perform system verification.

Macro Library Guide. This guide provides descriptions of Actel library elements for Actel device families. Symbols, truth tables, and module count are included for all macros.

ProASIC PLUS Macro Library Guide. This guide provides descriptions of Actel library elements for Actel ProASIC and ProASIC PLUS device families. Symbols, truth tables, and tile usage are included for all macros.

Online Help

The Designer Series software comes with online help. Online help specific to each software tool is available in Libero, Designer, ACTgen, ACTmap, Silicon Expert, Silicon Explorer II, Silicon Sculptor, and APSW.
Setup

This chapter contains information about setting up eProduct Designer to create Actel designs. This includes information about accessing the Actel and migration libraries, setting up eProduct Designer to interface with the Designer Series software, and setting up Actel projects in eProduct Designer. Refer to the Innoveda documentation for additional information about setting up eProduct Designer.

Software Requirements

The information in this guide applies to the Actel Designer Series software release R1-2000 or later and Innoveda eProduct Designer. For specific information about which versions this release supports, go to the Guru automated technical support system on the Actel web site (http://www.actel.com/guru) and type the following in the Keyword box:

third party

Actel Libraries

The Actel libraries contain models for each Actel macro in all Actel families for use in Innoveda. The Actel libraries are sufficient for most cases. Refer to “Migration Libraries” below for exceptions to using the Actel libraries.

Migration Libraries

In addition to the Actel libraries, Actel provides a set of migration libraries. These libraries contain macros supported in earlier versions of the Designer Series software and macros needed to retarget designs from a different Actel family. If you are upgrading from a previous version of Designer and you have existing Actel designs, you must use the migration libraries. Actel does not recommend using the migration libraries on new designs.
Chapter 1: Setup

The eProduct Designer software uses a “libs.lst” file to access the Actel libraries. When you install the Designer Series software, a “migrate.lst” file is automatically installed in the “c:\actel\lib\wv” directory. You must use this “migrate.lst” file as your “libs.lst” file to properly access the migration libraries.

To access the migration libraries, perform these steps:

1. (Optional) Create a backup copy of the “libs.lst” in the “c:\ePD\1.0\standard” directory.
2. Delete the “libs.lst” file in the “c:\ePD\1.0\standard” directory.
3. Copy the “migrate.lst” file in the “c:\actel\lib\wv” directory to the “c:\ePD1.0\standard” directory.
4. Rename the “migrate.lst” file as the “libs.lst” file in the “c:\ePD\1.0\standard” directory.

User Setup

Before creating designs, there are some one-time procedures to perform so that the eProduct Designer and Designer Series software can interface properly. This section describes those procedures.

Note: For ACTgen, make sure that environment variable “ePD_root” is set and “c:\ePD\1.1\wv\2000.2\win32\bin” is added to the path.

Actel EDIF Command

To automatically generate an Actel compatible EDIF netlist, add a custom command to the Tools menu in ViewDraw. Once added, this command appears as the Actel EDIF command. The following steps describe the procedure.

1. Invoke ViewDraw. If you have not already set up a project, the Project Manager Wizard dialog box is displayed. You must set up an Actel project for ViewDraw to open. Go to “Project Setup” on page 15 for the procedure.
2. **Open the Customize Tools Menu dialog box.** Choose the Customize command from the Tools menu.

3. **Add the Actel EDIF command.** Click the User Menu radio button. In the Menu Text box, type “Actel EDIF.” In the Command box, type or use the Browse button to select: “c:\ePD\1.0\wv\1999.2\win32\bin\edifneto.exe.” In the Arguments box, type “-L unit -L hard $BLOCKNAME,” Click OK. Figure 1-1 shows the configured Customize Tools Menu dialog box.

![Customize Tools Menu Dialog Box](image)

**Figure 1-1. Customize Tools Menu Dialog Box**

Before simulating VHDL netlists that reference Actel macros in Speedwave, you must compile Actel VITAL libraries. The following procedures describe the process.

1. **Create a directory called “swave” in the “c:\actel\lib\vtl\95” directory.**
2. **Set your project directory.** Invoke Project Manager and click the New button. Enter “swave” in the Project Name box and “c:\actel\lib\vtl\95\swave” in the Project Directory box. Click the Next button three times, then click the Finish button to complete the process. Do not set your library search order. The New Project Information box appears.

3. **Click the OK button in the New Project Information Dialog Box.**

4. **Save your project and exit Project Manager.**

5. **Open the VHDL Manager.** This displays the HDL Manager dialog box.

6. **Create a <vhd_fam> library.** Choose the Create command from the Library menu. Specify “c:\actel\lib\vtl\95\swave” in the Library Path box and <vhd_fam> in the Symbolic Name box. Click OK.

7. **Add system libraries to search order.** Make sure that the “SYNOPSYS.LIB” and “IEEE.LIB” libraries are listed under the VHDL System Libraries section in the VHDL View window.

8. **Add the Actel VITAL library to the <vhd_fam> library.** Choose the Add Source Files command from the Library menu. Select the <act_fam>.vhd file from the “c:\actel\lib\vtl\95\” directory. Click OK.

9. **Compile the Actel VITAL library.** Select the <act_fam>.vhd file in the VHDL View section of the HDL Manager window. Choose the Analyze Source File command from the Analyze menu.

10. **(Optional) Add the Actel VITAL Migration library to the <vhd_fam> library.** Select the <act_fam>_mig.vhd file from the “c:\actel\lib\vtl\95\” directory. Click OK.

11. **(Optional) Compile the Actel VITAL Migration library.** Select the <act_fam>_mig.vhd file in the VHDL View section of the HDL Manager window. Choose the Analyze Source File command from the Analyze menu.
Project Setup

You must set up an Actel project in the eProduct Designer Project Manager for each Actel design before creating your design in eProduct Designer. The following procedures describe the process.

1. **Invoke Dashboard.** From the Start menu, select eProduct Designer and Dashboard to open the Dashboard.

2. **Create or Open a project.** Click the New Project wizard. Choose to create or open a project.

3. **Set the Project Directory.** Type the full path name of your design directory in the Project Directory box or use the Browse button. Type the name of your project in the Project Name box. Click the OK button.

4. **Select an Actel FPGA library.** Choose a library in the Configured FPGA Libraries box. Click the icon of the Actel library you want to select, then click Next.

5. **(Optional) Add additional libraries.** Click the Add button and type the full path name of the library you want to add or use the Browse button.

6. **Click the Finish button in the Creating a New Project box.** The New Project information box appears. Click OK.

---

### Creating a Project Library in SpeedWave

If you use SpeedWave to simulate your designs, you must create a project library in SpeedWave, in addition to creating an Actel project in Project Manager, for each VHDL synthesis-based Actel project. The following procedures describe the process.

1. **Open the VHDL Manager from the simulation toolbox.** This displays the HDL Manager window.

2. **Setup a project.** Choose the Create command from the Library menu. The Create Library dialog box is displayed. Make sure the path in the Library Path box is correct and already exists. Type "user" in the Symbolic Name box and click OK. Make sure the Output window reports no errors in the Output window.
3. **Verify that the “user” library icon appears under the VHDL User Libraries section in the VHDL View window.**

4. **Add the compiled Actel VITAL library to the Project Libraries.**
   Choose the Add to Workspace command from the Library menu. The Add Existing Library to Workspace dialog box is displayed. Click the ellipsis box to open the Select Directory dialog box. Browse to the “c:\actel\lib\vtl\95\swave\<vhd_fam>.lib” directory and click OK. Click OK again in the Add Existing Library to Workspace dialog box. If you have not compiled the Actel VITAL library, go to “Compiling Actel VITAL Libraries” on page 13 for the procedure.

   **Note:** Only add the <vhd_fam>.lib if you have referenced Actel macros in your VHDL netlist.

5. **Add system libraries to the Project Libraries.** Make sure the “SYNOPSYS.LIB” and “IEEE.LIB” libraries are listed under VHDL System Libraries in the VHDL View window. If they are not present you must reinstall SpeedWave making sure to choose the Synopsys IEEE libraries when prompted.

6. **Save the project workspace.** Choose the Save command from the File menu.
This chapter describes the design flow for creating Actel designs using the eProduct Designer and Designer Series software.

Schematic-Based Design Flow Illustrated

Figure 2-1 shows the schematic-based design flow for creating an Actel device using the eProduct Designer and Designer Series software.1

---

1. The grey boxes in Figure 2-1 denote Actel-specific utilities/tools.
Chapter 2: Actel-Innoveda Design Flow

Schematic-Based Design Flow Overview

The Actel-Innoveda schematic-based design flow has four main steps: design creation/verification, design implementation, programming, and system verification. These steps are described in the following sections.

Design Creation/Verification

During design creation/verification, a schematic representation of a design is captured using the eProduct Designer ViewDraw software. After design capture, you can perform a prelayout (functional) simulation with the ePD ViewSim software. Finally, an EDIF netlist is generated for use in Designer.

Schematic Capture


Functional Simulation

Perform a functional simulation of your design using ViewSim before generating an EDIF netlist for place-and-route. Functional simulation verifies that the logic of the design is correct. Unit delays are used for all gates during functional simulation. Refer to “Functional Simulation” on page 33 and the Innoveda documentation for information about performing functional simulation.

EDIF Netlist Generation

After you have captured and verified your design, you must generate an EDIF netlist for place-and-route in Designer. Refer to “Generating an EDIF Netlist” on page 29 for information about generating an EDIF netlist.

Design Implementation

During design implementation, a design is placed-and-routed using Designer. Additionally, you can perform static-timing analysis on a design in Designer with the Timer tool. After place-and-route, perform postlayout (timing) simulation with the eProduct Designer ViewSim software.
Place-and-Route
Use Designer to place-and-route your design. Make sure you specify INNOVEDA as the Edif Flavor and Generic as the Naming Style when importing the EDIF netlist into Designer. Refer to the Designer User’s Guide for information about using Designer.

Static-Timing Analysis
Use the Timer tool in Designer to perform static-timing analysis on your design. Refer to the Timer User’s Guide for information about using Timer.

Timing Simulation
Perform a timing simulation of your design using ViewSim after placing-and-routing it in Designer. Timing simulation requires information extracted and back annotated from Designer. Refer to “Timing Simulation” on page 34 and the Innoveda documentation for information about performing timing simulation.

Programming
Program a device with programming software and hardware from Actel or a supported third-party programming system. Refer to the Activator and APS Programming System Installation and User’s Guide or Silicon Sculptor User’s Guide for information about programming an Actel device.

System Verification
You can perform system verification on a programmed device using the Actel Silicon Explorer diagnostic tool. Refer to the Activator and APS Programming System Installation and User’s Guide or Silicon Explorer Quick Start for information about using the Silicon Explorer.
VHDL Synthesis-Based Design Flow Illustrated

Figure 2-2 shows the VHDL synthesis-based design flow for an Actel device using the eProduct Designer and Designer Series software.

1. The grey boxes in Figure 2-2 denote Actel-specific utilities/tools.
VHDL Synthesis-Based Design Flow Overview

The Actel-Innoveda VHDL synthesis-based design flow has four main steps: design creation/verification, design implementation, programming, and system verification. Two verification tools are described, SpeedWave and ViewSim. Use SpeedWave if it is available. It is a VHDL simulator that allows you to perform behavioral, structural, and timing simulation. It also allows you to write stimulus in VHDL. If SpeedWave is not available, use ViewSim for structural and timing simulation. A description of these steps follows.

During design creation/verification, a design is captured in an RTL-level (behavioral) VHDL source file. After capture of the design, you may perform a behavioral simulation of the VHDL file with SpeedWave to verify that the VHDL code is correct. The code is then synthesized into a structural EDIF netlist using FPGA Express. After synthesis, you can perform a structural simulation of the design with SpeedWave or ViewSim. Import the EDIF netlist into Designer and perform a timing simulation using SpeedWave or ViewSim.

**VHDL Design Source Entry**

Enter your design source using a text editor or a context-sensitive VHDL editor. Your VHDL design source can contain RTL-level constructs, as well as instantiations of structural elements, such as ACTgen macros.

**Behavioral Simulation**

If SpeedWave is available, perform a behavioral simulation of your design before synthesis. Behavioral simulation verifies the functionality of your VHDL code. Typically, unit delays are used and a standard VHDL test bench can be used to drive simulation. Refer to “Behavioral Simulation” on page 37 and the Innoveda documentation for information about performing behavioral simulation.

**Synthesis**

Synthesize your design using FPGA Express. This transforms the behavioral VHDL file into a gate-level EDIF netlist, optimizing the design for a target technology.
Chapter 2: Actel-Innoveda Design Flow

Structural VHDL Netlist Generation
If you use SpeedWave for structural and timing simulation, generate a structural VHDL netlist from your EDIF netlist by either exporting it from Designer or by using the Actel “edn2vhdl” program. Refer to “Generating a Structural VHDL Netlist” on page 29 for information about generating a structural netlist.

Structural Simulation
Perform a structural simulation of your design before placing-and-routing it. Structural simulation verifies the functionality of your postsynthesis structural netlist. Unit delays are used for each gate. Refer to “Functional Simulation” on page 33 if using ViewSim or “Structural Simulation” on page 38 if using Speedwave. Also refer to the Innoveda documentation for information about performing structural simulation.

Design Implementation
During design implementation, use Designer to place-and-route a design. Additionally, you can perform static-timing analysis on a design in Designer with the Timer tool. After place-and-route, perform postlayout (timing) simulation with the Innoveda SpeedWave software.

Place-and-Route
Use Designer to place-and-route your design. Make sure to use GENERIC for the Edif flavor when importing the EDIF netlist into Designer. Refer to the Designer User’s Guide for information about using Designer.

Static-Timing Analysis
Use the Timer tool in Designer to perform static-timing analysis on your design. Refer to the Timer User’s Guide for information about using Timer.

Timing Simulation
Perform a timing simulation of your design after placing-and-routing it. Timing simulation uses information extracted from Designer, which overrides unit delays in the Actel VHDL. Refer to “Timing Simulation” on page 34 if using ViewSim or “Timing Simulation” on page 39 if
using SpeedWave. Also refer to the Innoveda documentation for information about performing timing simulation.

**Programming**

Program a device with programming software and hardware from Actel or a supported third-party programming system. Refer to the *Activator and APS Programming System Installation and User's Guide* or *Silicon Sculptor User's Guide* for information about programming an Actel device.

**System Verification**

You can perform system verification on a programmed device using the Actel Silicon Explorer diagnostic tool. Refer to the *Activator and APS Programming System Installation and User's Guide* or *Silicon Explorer Quick Start* for information about using the Silicon Explorer.
Actel-Innoveda Design Considerations

This chapter contains information to assist in creating Actel designs with the Innoveda eProduct Designer software. Topics include naming conventions, adding pins to the schematic, generating a top-level symbol, buried I/Os, adding power and ground, sheets and symbols, assigning pins in a schematic, adding ACTgen macros, adding FPGA Express blocks, generating an EDIF netlist, generating a structural VHDL netlist, using FPGA Express with SpeedWave, and using FPGA Express with VewSim.

Naming Conventions

Top-level blocks in ViewDraw and FPGA Express must have a design name that follows the DOS file-naming convention (e.g., 8.3 naming convention). The Actel back annotation program can only accept file names that follow this convention.

Use only alphanumeric and underscore "_" characters for schematic net and instance names. Do not use asterisks, forward and backward slashes, spaces, or periods.

Adding Pins to the Schematic

Add pins to the top-level schematic of the design by using the I/O buffer macros with a dangling net attached to the pad, as shown in Figure 3-1. The label on the dangling net becomes the I/O pin name.

![Figure 3-1. Adding Pins to a design](image)

Add and label this net

Add and label this net
Chapter 3: Actel-Innoveda Design Considerations

Generating a Top-Level Symbol

When generating a top-level symbol, ViewGen looks for an In or Out port. The convention is illustrated in Figure 3-2. ViewGen does not generate symbols for schematics without IN/OUT ports. The IN/OUT ports are found in the "c:\actel\lib\wv\asicbin" directory.

![Figure 3-2. Input/Output Ports](image)

Buried I/Os

I/O macros can be buried in the design hierarchy.

Adding Power and Ground

To add power or ground signals in the schematic, use the Actel VCC or GND symbols. You can also label the nets as VDD or GND.

Sheets and Symbols

A multiple-page design is composed of more than one schematic file or <design.n> file in the schematic directory. For a multiple-page design, treat each sheet as part of a top-level schematic and do not consider it a hierarchy level.
Assigning Pins in a Schematic

Nets in your schematic that have the “PIN” attribute assigned to them in ViewDraw are automatically assigned to that pin during design implementation in Designer.

To assign the “PIN” attribute to a net:

1. **Double-click the net to assign pin information.** This displays the Net Properties dialog box.
2. **Select the Attributes Tab.**
3. **Assign the “PIN” attribute to the net.** Type “PIN” in the Name box and the pin number to be assigned in the Value box. Click OK.

Note: This procedure assigns the pin name to the signal net in the netlist. If you use this method to fix pins and you change your pin assignments in PinEdit, you will not be able to back annotate. PinEdit does not change netlist information.

Adding ACTgen Macros

The ACTgen Macro Builder can automatically generate symbols that you can add to your schematic. The following steps describe the procedure.

1. **Invoke ACTgen.**
2. **Select the family, macro type, and macro options.**
3. **Generate your macro as a Innoveda symbol.** Make sure that you specify Innoveda as the Netlist/CAE Formats in the Generate Macro dialog box.
4. **Add the macro as a component in the schematic.** Refer to the Innoveda documentation for information about adding components to a schematic.

Refer to the *Using Designer Guide*, the *Guide to ACTgen Macros*, or the ACTgen online help for additional information about using ACTgen.
Adding FPGA Express Blocks

FPGA Express can generate blocks that can be added to your ViewDraw schematic. The following steps describe the procedure.

1. **Invoke FPGA Express.**
2. **Create a new project or open an existing one.** Add your VHDL source file(s) to the project.
3. **Create an implementation.** In the Create Implementation form, select “Do not insert I/O pads.”
4. **Export the Netlist.** In the Export form, select “%s<%d:%d>” for Bus Style and NONE for the Simulation Output Format.
5. **Save the Project and exit FPGA Express.**
6. **Translate the EDIF file into ViewDraw’s wir format.** Invoke the EDIF Interfaces program and select the EDIF Netlist Reader tab. Specify the EDIF file created by FPGA Express as the Input and your Innoveda project directory as your Output Dir.
7. **Invoke ViewGen to generate a symbol.** Specify the .wir file generated by the EDIF Netlist Reader as the input. Select “Generate the top level symbol” and optionally, “Generate schematic.”
8. **Add the symbol to your ViewDraw schematic.** Refer to the Innoveda documentation for information about adding symbols to a schematic.

Refer to the FPGA Express and other eProduct Designer online help for additional information.
Generating an EDIF Netlist

This section describes the procedures for generating an EDIF netlist for your design. Use the EDIF netlist for place-and-route in Designer.

To generate an EDIF netlist from a schematic-based design:
Select the Actel EDIF command from the Tools menu of ViewDraw. If you have not added the Actel EDIF command to the tools menu in ViewDraw, go to “Actel EDIF Command” on page 12 for the procedure.

To generate an EDIF netlist from a synthesis-based design:
FPGA Express creates an EDIF file that you can import directly into Designer. No special procedure is required.

Generating a Structural VHDL Netlist

You can generate a structural VHDL netlist for SpeedWave simulation from your EDIF netlist by either exporting it from Designer or by using the “edn2vhdl” program. The structural VHDL netlist generated by Designer and the “edn2vhdl” use std_logic for all ports. The bus ports are in the same bit order as they appear in the EDIF netlist.

To generate a structural VHDL netlist using Designer, perform these steps:

1. **Invoke Designer.**

2. **Import the EDIF netlist.** Select the Import Netlist File command from the File menu. The Import Netlist dialog box is displayed. Specify EDIF as the Netlist Type, GENERIC (or INNOVEDA if you are using an Innoveda synthesis tool) as the Edif Flavor. Type the full path name of your EDIF netlist or use the Browse button to select your design. Click OK.

3. **Export the structural VHDL netlist.** Select the Export command from the File menu. The Export dialog box is displayed. Specify Netlist File as the File Type and VHDL as the Format. Click OK.
To generate a structural VHDL netlist using edn2vhdl, perform these steps:

1. Open a DOS window.
2. Change to the directory that contains the EDIF netlist.
3. Translate the EDIF netlist to a structural VHDL Netlist. Type the following command at the prompt:
   
   \[ \text{edn2vhdl fam:<act_fam> <design_name>} \]

Using FPGA Express with SpeedWave

When using FPGA Express with SpeedWave, you do not need to use ViewDraw, ViewSim, ViewGen, or Innoveda EDIF interfaces. You use three point tools: SpeedWave, FPGA Express, and Designer.

1. Synthesize your design in FPGA Express. Create or open an existing FPGA Express project. Add your VHDL source file(s) to the project.
2. In the Create Implementation dialog box, be sure that the “Do not insert I/O pads” checkbox is not selected.
3. In the Export dialog box, select “%s<%d:%d>” for Bus Style and NONE for the Simulation Output Format. An EDIF netlist is exported by FPGA Express.
Using FPGA Express with ViewSim

When using FPGA Express with ViewSim, you cannot perform a behavioral simulation. You need to import the synthesized design into the ViewDraw/ViewSim environment.

1. **Synthesize your design in FPGA Express.** Create or open an existing FPGA Express project. Add your VHDL source file(s) to the project.

2. **In the Create Implementation form, make sure that the “Do not insert I/O pads” checkbox is not selected.**

3. **In the Export dialog box, select “%s<%d:%d>” for Bus Style and NONE for the Simulation Output Format.** FPGA Express exports an EDIF netlist.

4. **Import the synthesized EDIF into the ViewDraw/ViewSim environment.** Invoke the EDIF Interfaces program and select the EDIF Netlist Reader tab. Specify the EDIF file created by FPGA Express as the Input and your Innoveda project directory as your Output Dir.
Simulation Using ViewSim

This chapter describes the procedures for performing functional and timing simulations of an Actel design using the Innoveda ViewSim simulation tool.

Functional Simulation

Use the following procedure to perform a functional simulation of an Actel design:

1. **Select your Actel project in the Dashboard.** If you have not created or setup your project, go to “Project Setup” on page 15 for the procedure.

2. **Open the ViewSim Wirelister dialog box.** Invoke ViewVSM or, from ViewDraw, choose the Create Digital Netlist command from the Tools menu.

3. **Generate a simulation (.vsm) wirelist.** Type in the design name or use the Browse button. Click OK. A simulation wirelist is generated and the eProduct Designer window is displayed.

4. **Simulate the design.** Invoke ViewSim. Type in the design name in the Design Name box and click OK.

Refer to the Innoveda documentation for additional information about performing simulation with ViewSim.
Timing Simulation

Use the following procedure to perform a timing simulation of an Actel design:

1. **Place-and-route your design in Designer.** Refer to the Using Designer Guide for information on using Designer.

2. **Extract timing information for your design.** Choose the Export command from the File menu or click the BackAnnotate button. The Extract dialog box is displayed. Create a `<design_name>.stf` file by choosing the GENERIC option from the CAE pull-down menu. Click OK.

3. **Back annotate your delays.** Select the Innoveda back-annotate icon from the Designer Series group. The Open dialog box is displayed. Select the `<design_name>.stf` file and click OK to generate the `<design_name>.dtb` file and the `<design_name>.vsm` file for use with ViewSim.

4. **Select your Actel project in Project Manager.** If you have not created or setup your project see “Project Setup” on page 15.

5. **Simulate the design.** Invoke ViewSim. Choose the Load Design from the File menu. The Load compiled VSM file dialog box is displayed. Select the `<design_name>.vsm` file created in step 3 and click OK.

Refer to the Innoveda documentation for additional information about performing simulation with ViewSim.
Multichip Simulation

System designs are typically divided into functional modules implemented by several Actel devices. To check the functionality of the system, you must simulate all Actel devices together. You can use ViewSim and Designer to perform multichip simulation. Use the following procedure to perform a multichip simulation of an Actel design:

Note: Because the viewdraw.ini file uses the same alias for all Actel families, you can only simulate multiple Actel devices of the same family.

1. **Create a top-level schematic and instantiate the individual chip designs.** This example assumes there are three designs with instance names “chip1,” “chip2,” and “chip3.” The name of the top-level schematic is “top.” Figure 4-1 depicts the directory structure for this example. Names written in normal text represent file names and those in bold text represent directory names.

![Figure 4-1. Directory Structure for Multichip Simulation](image)

Note: This example only contains single-sheet schematics for each design. Similar procedures apply to multiple-sheet designs.

2. **Place-and-route your design in Designer.** Refer to the Using Designer Guide for information about using Designer.
3. **Extract timing information for your design.** Choose the Extract command from the Tools menu or click the Extract button. The Extract dialog box is displayed. Create a “chip1.stf” file by choosing the GENERIC option from the CAE pull-down menu. Click OK. Repeat for “chip2.stf” and “chip3.stf.”

4. **Backannotate your delays.** Select the Innoveda back-annotate icon from the Designer Series group. The Open dialog box is displayed. Select the “chip1.stf” file and click OK to generate the “chip1.dtb” file. Repeat for the “chip2.dtb” and “chip3.dtb” files.

5. **Generate a “top.dtb” file for the top-level schematic.** The top-level DTB file includes the following lines:

```
.ba
    c chip1
    a dtb=chip1.dtb
    c chip2
    a dtb=chip2.dtb
    c chip3
    a dtb=chip3.dtb
.ab
```

The “c” line above specifies an instance name, “chip1.” If you have not labeled an instance, use the default handle name of an instance, “$1I38” as it appears in your top-level schematic. Also, the individual DTB files reside in the top-level design directory, “top.”

6. **Run ViewVSM on “top.dtb.”** Reference the “top.dtb” file in the VSM pop-up dialog box. The VSM program processes the DTB files for each chip and creates the “top.vsm” file with back-annotated postlayout timing delays.

7. **Simulate “top.vsm.”** Invoke ViewSim. Type “top.vsm” in the Design Name box and click OK.

Refer to the Innoveda documentation for additional information about performing simulation with ViewSim.
This chapter describes the procedures for performing behavioral, structural, and timing simulations of an Actel design using the Innoveda SpeedWave simulation tool.

**Behavioral Simulation**

Use the following procedures to perform a behavioral simulation of an Actel design. Refer to the Innoveda documentation for additional information about performing simulation with SpeedWave:

1. **Select your Actel project in Project Manager.** If you have not created your project, go to “Project Setup” on page 15 for the procedure.
2. **Open the HDL Manager.** This displays the HDL manager dialog box.
3. **Open a project HDL workspace (.hws) file.** Choose the Open command from the File menu. Select an .hws file and click the Open button in the Open dialog box.
4. **Analyze your behavioral VHDL design files and testbench.**
   Select the user library icon in the VHDL User Libraries section of the VHDL View window. Choose the Add Source Files command from the Library menu. The Assign Source Files dialog box is displayed. Select the behavioral VHDL and testbench files from the VHDL Source File Name window and click OK. Select each file and choose the Analyze Source File command from the Analyze menu. Check the Output window for successful completion. Save the HDL workspace and close the HDL Manager window.

   **Note:** SpeedWave can only simulate configurations. You must have at least one configuration in your testbench.

5. **Select a configuration to simulate.** Choose the Load Design command from the File menu. Double-click “user.lib” and select the configuration you want to simulate. Click OK. A Source Viewer window and a Hierarchy Viewer window are displayed.
6. **Simulate your design.** Choose the Run Simulation command from the Simulate menu. The Run Simulation dialog box is displayed.
Chapter 5: Simulation Using SpeedWave

Select the desired options and click the Apply button. Click the Close button when you have completed your simulation.

Structural Simulation

Use the following procedures to perform a structural simulation of an Actel design. Refer to the Innoveda documentation for additional information about performing simulation with SpeedWave.

1. **Synthesize your design.** Refer to the documentation included with your synthesis tool for information about synthesis.

2. **Select your Actel project in Project Manager.** If you have not created your project, go to “Project Setup” on page 15 for the procedure.

3. **Open the HDL Manager.** This displays the HDL manager dialog box.

4. **Open a project HDL workspace (.hws) file.** Choose the Open command from the File menu. Select an .hws file and click the Open button in the Open dialog box.

5. **Analyze your structural VHDL netlist and testbench.** If you have not already generated a structural VHDL netlist, go to “Generating a Structural VHDL Netlist” on page 29 for the procedure. Select the user library icon in the VHDL User Libraries section of the VHDL View window. Choose the Add Source Files command from the Library menu. The Assign Source Files dialog box is displayed. Select the structural VHDL netlist and testbench files from the VHDL Source File Name window and click OK. Select each file and choose the Analyze Source File command from the Analyze menu. Check the Output window for successful completion. Save the HDL workspace and close the HDL Manager window.

   **Note:** SpeedWave can only simulate configurations. You must have at least one configuration in your testbench.

6. **Select a configuration to simulate.** Choose the Load Design command from the File menu. Double-click “user.lib” and select the
Timing Simulation

Use the following procedures to perform a timing simulation of an Actel design. Refer to the Innoveda documentation for additional information about performing simulation with SpeedWave.

1. **Place-and-route your design in Designer.** Refer to the Using Designer Guide for information about using Designer.

2. **Extract timing information for your design from Designer.** Choose the Extract command from the Tools menu or click the Extract button. The Extract dialog is displayed. Create a `<design_name>.sdf` file by choosing the SDF option from the CAE pull-down menu. Click OK.

3. **Select your Actel project in Project Manager.** If you have not created a project, go to “Project Setup” on page 15 for the procedure.

4. **Open the HDL Manager.** This displays the HDL manager dialog box.

5. **Open a project HDL workspace (.hws) file.** Choose the Open command from the File menu. Select an .hws file and click the Open button in the Open dialog box.

6. **(Optional) Analyze your VHDL design files and testbench.** Skip this step if you are using the same structural VHDL netlist and testbench you analyzed for structural simulation. Select the user library icon in the VHDL User Libraries section of the VHDL View window. Choose the Add Source Files command from the Library menu. The Assign Source Files dialog box is displayed. Select the structural VHDL netlist and testbench files from the VHDL Source File Name window and click OK. Select each file and choose the configuration you want to simulate. Click OK. A Source Viewer window and a Hierarchy Viewer window are displayed.

7. **Simulate your design.** Choose the Run Simulation command from the Simulate menu. The Run Simulation dialog box is displayed. Select the desired options and click the Apply button. Click the Close button when you have completed your simulation.
Chapter 5: Simulation Using SpeedWave

Analyze Source File command from the Analyze menu. Check the Output window for successful completion. Save the HDL workspace and close the HDL Manager window.

Note: SpeedWave can only simulate configurations. You must have at least one configuration in your testbench.

7. **Select a configuration to simulate.** Choose the Load Design command from the File menu. Double-click "user.lib" and select the configuration you want to simulate. Click OK. A Source Viewer window and a Hierarchy Viewer window are displayed.

8. **Import the timing information for your design.** Click the VITAL Timing index tab. Click the Perform SDF Back Annotation check box and click OK. Click the SDF Back Annotation tab to activate the dialog box. Type the name of your <design_name>.sdf in the SDF File box or use the Browse button.

9. **Add Scope options.** In the Scope window, fill in the name of the instance in the testbench you want to back annotate (e.g. "/uut"). Select the Delay Mode you want use (Minimum, Typical, or Maximum). Click the Add button and verify that the Scope, File, and Timing settings are correct in the main window. Use the Change and Remove buttons to make any corrections.

10. **Back annotate your design.** Click OK.

11. **Simulate your design.** Choose the Run Simulation command from the Simulate menu. The Run Simulation dialog box is displayed. Select the desired options and click the Apply button. Click the Close button when you have completed your simulation.
Product Support

Actel backs its products with various support services including Customer Service, a Customer Applications Center, a web site, an FTP site, electronic mail, and worldwide sales offices. This appendix contains information about contacting Actel and using these support services.

Actel U.S. Toll-Free Line

Use the Actel toll-free line to contact Actel for sales information, technical support, requests for literature about Actel and Actel products, Customer Service, investor information, and using the Action Facts service.

The Actel toll-free line is (888) 99-ACTEL.

Customer Service

Contact Customer Service for nontechnical product support, such as product pricing, product upgrades, update information, order status, and authorization.

From Northeast and North Central U.S.A., call (408) 522-4480.
From Southeast and Southwest U.S.A., call (408) 522-4480.
From South Central U.S.A., call (408) 522-4434.
From Northwest U.S.A., call (408) 522-4434.
From Canada, call (408) 522-4480.
From Europe, call (408) 522-4252 or +44 (0) 1256 305600.
From Japan, call (408) 522-4743.
From the rest of the world, call (408) 522-4743.
Fax, from anywhere in the world (408) 522-8044.
Customer Applications Center

Actel staffs its Customer Applications Center with highly skilled engineers who can help answer your hardware, software, and design questions. The Applications Center spends a great deal of time creating application notes and answers to FAQs. So, before you contact us, please visit our online resources. It is very likely we have already answered your question(s).

Guru Automated Technical Support

Guru is a web-based automated technical support system accessible through the Actel home page (http://www.actel.com/guru/). Guru provides answers to technical questions about Actel products. Many answers include diagrams, illustrations, and links to other resources on the Actel web site. Guru is available 24 hours a day, seven days a week.

Web Site

Actel has a World Wide Web home page where you can browse a variety of technical and nontechnical information. Use a Net browser (Netscape recommended) to access Actel's home page.

The URL is http://www.actel.com. You are welcome to share the resources provided on the Internet.

Be sure to visit the Technical Documentation area on our web site, which contains information regarding products, technical services, current manuals, and release notes.

You can visit the Product Support area of the Actel website from your Designer software. Click the Product Support button in your Designer Main Window to access the latest datasheets, application notes, and more.
FTP Site

Actel has an anonymous FTP site located at ftp://ftp.actel.com. Here you can obtain library updates, software patches, design files, and data sheets.

Contacting the Customer Applications Center

Highly skilled engineers staff the Customer Applications Center from 7:30 A.M. to 5:00 P.M., Pacific Time, Monday through Friday. Several ways of contacting the Center follow:

Electronic Mail

You can communicate your technical questions to our e-mail address and receive answers back by e-mail, fax, or phone. Also, if you have design problems, you can e-mail your design files to receive assistance. We constantly monitor the e-mail account throughout the day. When sending your request to us, please be sure to include your full name, company name, and your contact information for efficient processing of your request.

The technical support e-mail address is tech@actel.com.

Telephone

Our Technical Message Center answers all calls. The center retrieves information, such as your name, company name, phone number and your question, and then issues a case number. The Center then forwards the information to a queue where the first available application engineer receives the data and returns your call. The phone hours are from 7:30 A.M. to 5:00 A.M., Pacific Time, Monday through Friday.

The Customer Applications Center number is (800) 262-1060.

European customers can call +44 (0) 1256 305600.
Appendix A: Product Support

Worldwide Sales Offices

Headquarters
Actel Corporation
955 East Arques Avenue
Sunnyvale, California 94086
Toll Free: 888.99.ACTEL
Tel: 408.739.1010
Fax: 408.739.1540

US Sales Offices

California
Bay Area
Tel: 408.328.2200
Fax: 408.328.2358
Irvine
Tel: 949.727.0470
Fax: 949.727.0476
Newbury Park
Tel: 805.375.5769
Fax: 805.375.5749

Colorado
Tel: 303.420.4335
Fax: 303.420.4336

Florida
Tel: 407.977.6846
Fax: 407.977.6847

Georgia
Tel: 770.277.4980
Fax: 770.277.5896

Illinois
Tel: 847.259.1501
Fax: 847.259.1575

Massachusetts
Tel: 978.244.3800
Fax: 978.244.3820

Minnesota
Tel: 651.917.9116
Fax: 651.917.9114

New Jersey
Tel: 609.517.0304

North Carolina
Tel: 919.654.4529
Fax: 919.674.0055

Pennsylvania
Tel: 215.830.1458
Fax: 215.706.0680

Texas
Tel: 972.235.8944
Fax: 972.235.965

International Sales Offices

Canada
235 Stafford Rd. West,
Suite 106
Nepean, Ontario K2H 9C1
Tel: 613.726.7575
Fax: 613.726.8866

France
Actel Europe S.A.R.L.
361 Avenue General de Gaulle
92147 Clamart Cedex
Tel: +33 (0)1.40.83.11.00
Fax: +33 (0)1.40.94.11.04

Germany
Lohweg 27
85375 Neufahrn
Tel: +49 (0)8165.9584.0
Fax: +49 (0)8165.9584.1

Italy
Via de Garibaldini, No. 5
20019 Settimo Milanese,
Milano, Italy

Japan
EXOS Ebisu Building 4F
1-24-14 Ebisu Shibuya-ku
Tokyo 150
Tel: +81 (0)3.3445.7671
Fax: +81 (0)3.3445.7608

Korea
30th Floor, ASEM Tower,
159-1 Samsung-dong,
Kangnam-ku,
Seoul, Korea
Tel: +82.2.6001.3382
Fax: +82.2.6001.3050

United Kingdom
Maxfli Court,
Riverside Way
Camberley,
Surrey GU15 3YL
Tel: +44 (0)1276.401452
Fax: +44 (0)1276.401490
Index

Symbols
<act_fam> variable vi
<vhd_fam> variable vi

A
Actel vi
   Device Families vi
   EDIF command 12
   FPGA Libraries 15
   FTP Site 43
   Web Based Technical Support 42
   Web Site 42
   Actel Manuals vii
   Actel Project Setup 15–16
   Project Manager 15
   SpeedWave 15
   Actel VITAL Libraries
      Compiling 13
      Creating an swave Directory 13
   ACTgen, Generating Symbols 27
   Adding
      Actel EDIF command 12
      Pins in a Schematic 27
      Pins to a Top-Level Schematic 25
      Power and Ground Symbols 26
      VHDL Blocks 28
   Analyzing
      Test Bench 37, 38, 39
      VHDL Source File 37, 38, 39
   Arguments
      EDIF Netlister 13
   Assigning
      Nets 27
      Pins 27
   Assumptions vi

B
Back Annotate 34, 36, 40
   DTB File 34, 36
   Naming Conventions 25
   VSM File 34, 36
   Behavioral Simulation 21, 37
   SpeedWave 21, 37
   Buried I/O Macros 26

C
Capturing a Design
   Schematic-Based 18
   VHDL-Based 21
   Compiling Actel VITAL Libraries 13
   Configuration 37, 38, 40
   Configuring EDIF Netlister 12
   Contacting Actel
      Customer Service 41
      Electronic Mail 43
      Technical Support 42
      Toll-Free 41
      Web Based Technical Support 42
   Conventions vi
      <act_fam> variable vi
      <vhd_fam> variable vi
   Creating
      Macros 27
      SDF File 39
      STF File 34, 36
      swave Directory 13
   Customer Service 41
   Customizing ViewDraw 12

D
Dangling Net 25
   Delay Mode 40
Index

Design Creation/Verification 18, 21
   Behavioral Simulation 21
   EDIF Netlist Generation 18
   Functional Simulation 18
   Schematic Capture 18
   Structural Netlist Generation 22
   Structural Simulation 22
   Synthesis 21
   VHDL Source Entry 21

Design Flow
   Design Creation/Verification 18, 21
   Design Implementation 18, 22
   Schematic-Based 18–19
   VHDL Synthesis-Based 20–23

Design Implementation 18, 22
   Place-and-Route 19, 22
   Timing Analysis 19, 22
   Timing Simulation 19, 23

Design Layout 19, 22
Design Synthesis 21

Designer
   EDIF Option 29
   Extracting Timing Information 34, 36, 39
   GENERIC Option 34, 36
   Place-and Route 22
   Place-and-Route 19
   SDF Option 39
   Software Installation Directory vi
   Timer Tool 19, 22
   Timing Analysis 19, 22
   VHDL Option 22
   VIEWLOGIC Option 22, 29

Device
   Debugging 19, 23
   Families vi
   Programming 19, 23

Digital Netlist Generation 33
Document
   Assumptions vi
   Conventions vi
   Organization v
   DTB file 34, 36

E
   EDIF Netlist Generation
      Schematic-Based 18, 29
      Synthesis-Based 29
   EDIF Netlister Arguments 13
   EDIF Option 29
   Electronic Mail 43
   Extracting Timing Information 34, 36, 39

F
   Fixing Pins 27
   FPGA Express
      Adding Blocks 28
      Design Synthesis 21
      Generating Symbols 28
      Synthesis Considerations 30
      Use In VHDL Flow 21
   FPGA Libraries 15
   Functional Simulation 18, 33
      ViewSim 18, 33

G
   Gate-Level Netlist 21
   Generating
      Digital Netlist 33
      DTB File 34, 36
      EDIF Netlist 18
      Gate-Level Netlist 21
      Simulation Wirelist 33, 36
Index

Structural Netlist 22
Top-Level Symbol 26
VSM File 33, 34, 36
Generating Symbols
ACTgen 27
FPGA Express 28
GENERClc Option 34, 36
GND 26

I
I/O Macros 26
Importing Timing Information 40
In/Out Ports 26
Installation Directory
Designer vi
Workview Office vi
Instance Name 36

L
Libraries
Actel FPGA 15
Actel VITAL 13
Project 15

M
Macros 27
Multichip Simulation 35–36
Directory Structure 35
Multiple-Sheet Schematic 26, 35

N
Netlist Generation
Digital 33
EDIF 18
Gate-Level 21
Structural 22

O
Online Help ix

P
PinEdit 27
Pins
Assigning 27
Attribute 27
Back Annotate 27
PinEdit 27
Place-and-Route 19, 22
Post-Synthesis Simulation 23
Primary Directory 15
Product Support 41–44
Customer Applications Center 42
Customer Service 41
Electronic Mail 43
FTP Site 43
Technical Support 42
Toll-Free Line 41
Web Site 42
Programming a Device 19, 23
Project Manager
Project Setup 15
Selecting an Actel FPGA Library 15
Setting the Primary Directory 15
Project Setup 15–16
Project Manager 15
SpeedWave 15

R
Required Software 11

S
Schematic Capture 18
Schematic Design Considerations 25–27
Index

Adding Pins in a Schematic 27
Adding Pins to a Top-Level Schematic 25
Adding Power and Ground 26
Adding VHDL Blocks 28
Creating Macros 27
Generating a Top-Level Symbol 26
I/O Macros 26
Multiple-Page Design 26
Naming Conventions 25
Schematic Naming Conventions 25
Schematic-Based Design Flow 18–19
  Design Creation/Verification 18
  Design Implementation 18
  Programming 19
  System Verification 19
Scope Options 40
SDF
  File 39
  Option 39
Selecting
  An Actel FPGA Library 15
  Scope Options 40
Setting the Primary Directory 15
Setting Up
  an Actel Project in Project Manager 15
  an Actel Project in SpeedWave 15
  SpeedWave 13
  ViewDraw 12
Setup Procedures 12–16
  Adding the Actel EDIF command 12
  Compiling Actel VITAL Libraries 13
  Creating a Project Library 15
  Project Setup 15–16
  Setting Up an Actel Project 15
  User Setup 12–14
Simulation
  Behavioral 21, 23
  Configuration 37, 38, 40
  Functional 18, 33
  Multichip 35
  Post-Synthesis 23
  Schematic-Based 18, 19, 33–36
  SpeedWave 21, 22, 23, 37–40
  Structural 22, 33, 38
  Synthesis-Based 21, 22, 23, 37–40
  Test Bench 37, 38, 40
  Timing 19, 23, 34, 39
  ViewSim 18, 19, 22, 33–36
Simulation Wirelist, Generating 33, 36
Software Requirements 11
SpeedWave
  Behavioral Simulation 21, 37
  Compiling Actel VITAL Libraries 13
  Creating a Project Library 15
  Importing Timing Information 40
  Post-Synthesis Simulation 23
  Scope Options 40
  Set Up 13
  Structural Simulation 22, 38
  Timing Simulation 23, 39
  Static Timing Analysis 19, 22
  STF file 34, 36
  Structural Netlist Generation 22
    GENERIC Option 29
    VIEWLOGIC Option 29
  Structural Simulation 22, 33, 38
    SpeedWave 22, 38
    VIEWLOGIC Option 29
    ViewSim 22, 33
  swave Directory 13
  Synthesis 21
  System Requirements 11
System Verification 19, 23
Silicon Explorer 19, 23

T
Technical Support 42
Test Bench 37, 38, 39
Timer
  Static Timing Analysis 19, 22
  Timing Analysis 19, 22
  Timing Information 34, 36, 39, 40
  SDF File 39
  STF File 34, 36
Timing Simulation 19, 22, 34, 39
  GENERIC Option 34, 36
  SDF
    Option 39
    SpeedWave 23, 39
  ViewSim 19, 34
Toll-Free Line 41
Top-Level
  Schematic 25, 35
  Symbol 26

U
Unit Delays 18, 21
User Setup 12–14

V
variables
  <act_fam> vi
  <vhd_fam> vi
VCC 26
VDD 26
VHDL Option 22
VHDL Source Entry 21
VHDL Source File
  Analyzing 37, 38, 39
  VHDL Synthesis-Based Design Flow 20–23
    Design Creation/Verification 21
    Design Implementation 22
    Programming 23
    System Verification 23
ViewDraw
  Alias 35
  Creating an Actel EDIF Netlist 12
  Customizing 12
  Set Up 12
viewdraw.ini File
  Alias 35
ViewGen
  Generating Symbols for Schematics 26
VIEWLOGIC Option 22, 29
ViewSim
  Adding Pins in a Schematic 27
  Adding Pins to a Top-Level Schematic 25
  Adding Power and Ground 26
  Creating Macros 27
  Functional Simulation 18, 33
  Generating a Top-Level Symbol 26
  I/O Macros 26
  Multichip Simulation 35
  Multiple-Page Design 26
  Naming Conventions 25
  Schematic Design Considerations 25–27
  Structural Simulation 22, 33
  Timing Simulation 19, 34
ViewVSM, Generating a Simulation Wirelist 33, 36
VSM File 33, 34, 36

W
Web Based Technical Support 42
Index

Workview Office, Software Installation Directory
vi